summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-10-28 16:36:57 -0700
committerZac Medico <zmedico@gentoo.org>2016-10-28 16:38:09 -0700
commit74b540331037070b1090b239dbe814eeb8d7497a (patch)
tree3e020b5b30210422ee1a30671de8b6090323ec2b /dev-util/bazel
parentdev-python/m2crypto: Add missing RDEPEND on dev-python/typing (diff)
downloadgentoo-74b540331037070b1090b239dbe814eeb8d7497a.tar.gz
gentoo-74b540331037070b1090b239dbe814eeb8d7497a.tar.bz2
gentoo-74b540331037070b1090b239dbe814eeb8d7497a.zip
dev-util/bazel: add package
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-util/bazel')
-rw-r--r--dev-util/bazel/Manifest1
-rw-r--r--dev-util/bazel/bazel-0.3.2.ebuild34
-rw-r--r--dev-util/bazel/metadata.xml10
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-util/bazel/Manifest b/dev-util/bazel/Manifest
new file mode 100644
index 000000000000..387eb8fd625c
--- /dev/null
+++ b/dev-util/bazel/Manifest
@@ -0,0 +1 @@
+DIST bazel-0.3.2.tar.gz 145095554 SHA256 9692ac3318a40e8a0530f68bbfc473ae5f6a4a5c0fe08d2f88612ca4d40ba54a SHA512 975faf5830e952bea5d3fa8d127e0d5d9654af83f1fba0d7e26f9e1c2c71dd58542efea2382b0c52c9fd24ae43ec66a3ca7451309f02fd65c0896bbbdb3c79f5 WHIRLPOOL ab487f84e8126ab2badfd84d1fe757170900fbb2f88dff79d6867fb694bbb8adf226b7b89bfdb9cf207595bfd235583a54b8102a1a009f58be7bd3be039e1aaa
diff --git a/dev-util/bazel/bazel-0.3.2.ebuild b/dev-util/bazel/bazel-0.3.2.ebuild
new file mode 100644
index 000000000000..a02451f65a0e
--- /dev/null
+++ b/dev-util/bazel/bazel-0.3.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit bash-completion-r1 java-pkg-2
+
+DESCRIPTION="Bazel build system"
+HOMEPAGE="https://bazel.io/"
+SRC_URI="https://github.com/bazelbuild/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+# strip corrupts the bazel binary
+RESTRICT="strip"
+DEPEND="virtual/jdk:1.8"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ ./compile.sh || die
+ # Use standalone strategy to deactivate the bazel sandbox, since it
+ # conflicts with FEATURES=sandbox.
+ echo "build --spawn_strategy=standalone --genrule_strategy=standalone" \
+ > "${T}/bazelrc" || die
+ output/bazel --bazelrc="${T}/bazelrc" build //scripts:bazel-complete.bash || die
+}
+
+src_install() {
+ dobin output/bazel
+ newbashcomp bazel-bin/scripts/bazel-complete.bash ${PN}
+}
diff --git a/dev-util/bazel/metadata.xml b/dev-util/bazel/metadata.xml
new file mode 100644
index 000000000000..6fa37547639c
--- /dev/null
+++ b/dev-util/bazel/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">bazelbuild/bazel</remote-id>
+ </upstream>
+</pkgmetadata>