summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-06-12 17:45:51 +1000
committerMichael Palimaka <kensington@gentoo.org>2017-06-12 17:46:55 +1000
commit4a4588e4108d0493879cabc47d08ef748a9baa7e (patch)
tree61a535254a92d83361992aeef3a45198a8e04289 /dev-util/bcpp
parentsys-kernel/mips-sources: version bumps for 4.4, 4.9, 4.10, and 4.11 (diff)
downloadgentoo-4a4588e4108d0493879cabc47d08ef748a9baa7e.tar.gz
gentoo-4a4588e4108d0493879cabc47d08ef748a9baa7e.tar.bz2
gentoo-4a4588e4108d0493879cabc47d08ef748a9baa7e.zip
dev-util/bcpp: port to EAPI 6 and fix LICENSE
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-util/bcpp')
-rw-r--r--dev-util/bcpp/bcpp-20150811-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/bcpp/bcpp-20150811-r1.ebuild b/dev-util/bcpp/bcpp-20150811-r1.ebuild
new file mode 100644
index 000000000000..bf4cc3ad2bad
--- /dev/null
+++ b/dev-util/bcpp/bcpp-20150811-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Indents C/C++ source code"
+HOMEPAGE="http://invisible-island.net/bcpp/"
+SRC_URI="ftp://invisible-island.net/bcpp/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+src_compile() {
+ emake CPPFLAGS='-DBCPP_CONFIG_DIR=\"/etc/bcpp/\"'
+}
+
+src_install() {
+ default
+ dodoc CHANGES MANIFEST README VERSION txtdocs/hirachy.txt \
+ txtdocs/manual.txt
+
+ insinto /etc/bcpp
+ doins bcpp.cfg indent.cfg
+}
+
+pkg_postinst() {
+ elog "Check the documentation for more information on how to"
+ elog "Run bcpp. Please note that in order to get help for"
+ elog "bcpp, please run bcpp -h and not the command by itself."
+ elog ""
+ elog "Configuration files are at /etc/bcpp."
+ elog "To use them, use the -c option followed by the filename."
+}