summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2018-03-13 20:34:46 +0000
committerBrian Dolbec <dolsen@gentoo.org>2018-03-13 23:56:34 +0000
commit704b45326d83ebfb61ae48b594b2bc74e31fa770 (patch)
treeb9023078433398eff01208c48b40e6b4a398ee73 /dev-util/buildbot-console-view
parentdev-util/buildbot-waterfall-view: Version bump (diff)
downloadgentoo-704b45326d83ebfb61ae48b594b2bc74e31fa770.tar.gz
gentoo-704b45326d83ebfb61ae48b594b2bc74e31fa770.tar.bz2
gentoo-704b45326d83ebfb61ae48b594b2bc74e31fa770.zip
dev-util/buildbot-console-view: Version bump
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-util/buildbot-console-view')
-rw-r--r--dev-util/buildbot-console-view/Manifest1
-rw-r--r--dev-util/buildbot-console-view/buildbot-console-view-1.1.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-util/buildbot-console-view/Manifest b/dev-util/buildbot-console-view/Manifest
index 6dde5f7c08a2..6ddb50d435b1 100644
--- a/dev-util/buildbot-console-view/Manifest
+++ b/dev-util/buildbot-console-view/Manifest
@@ -3,3 +3,4 @@ DIST buildbot-console-view-0.9.11.tar.gz 640623 BLAKE2B b364c99609696d4264faab85
DIST buildbot-console-view-0.9.12.tar.gz 640923 BLAKE2B cc0da84395aca571803e73260d826633553ed10ede6d66d112dfa8bcdc4f1bd376695ee0ee4a715f1fa3705329033044d9358731c0b807c54b40b4e32a04f565 SHA512 4a73994c29fe1f78c4432bdb42fe14106b8d7887bb35f2835b203f4818844d3e8d2ea308fc4fb2bd562de302bd7cf6612fe047476512feac068eca3891a49522
DIST buildbot-console-view-0.9.13.tar.gz 640969 BLAKE2B e0c6449c8208a34e568ed632be61fda0ae6ef0b183cd53e2288e1b89e03df6a874ec363f3cfdfa15005bc2913084eaf8640e86abf1ad2d19609e7b4c818f7b77 SHA512 16a3186a97112473fa1f7e811ceffe9f829d6181544e62290172b97b898ddb189fe8e67e223a3e02c936e61fc857a05e0b353dda7e5d4a3ce782f74a32515d2f
DIST buildbot-console-view-0.9.15.post1.tar.gz 640548 BLAKE2B d28d3fbe40a8ceeaf574d2e8a9a6938664659dc6221a9e7e288c98b771cf7601a8db125dfb3cd71c500aee470a2b476a9daa0d5ec55a83758a96e97e14441def SHA512 42ad7d9dfdf0b3b0cda8d8dcd3fb2bd6734a775755fdc4ebe79d562f5ffb45d0e25d3ece15dec4a7542dd29e45a721e683bec416582901dbfa519c8da76cfa78
+DIST buildbot-console-view-1.1.0.tar.gz 640524 BLAKE2B 038412232299b9dcf5b38c0dcc646bce0f02c817b319bc796268e0bdcd10db0a82dbeb692850ad252246a2a0b48ceca23fd5ac900d46774b64ea19839673f607 SHA512 c45962f73d8e8214518c09fc3163d20f93ac4f55ed547dc90f4116906b94a01384bdc28e52d1b850ba34077c4cd30cd3e1f2dae23c01e233e5745de181e2dc6c
diff --git a/dev-util/buildbot-console-view/buildbot-console-view-1.1.0.ebuild b/dev-util/buildbot-console-view/buildbot-console-view-1.1.0.ebuild
new file mode 100644
index 000000000000..5f6501c2a710
--- /dev/null
+++ b/dev-util/buildbot-console-view/buildbot-console-view-1.1.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"
+
+[[ ${PV} == *9999 ]] && inherit git-r3
+inherit distutils-r1
+
+DESCRIPTION="Buildbot console-view plugin"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.python.org/pypi/buildbot-console-view"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+
+IUSE="test"
+
+RDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"
+#[[ ${PV} == *9999 ]] && S=${S}/www/base
+
+python_test() {
+ distutils_install_for_testing
+
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}