summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-28 23:07:17 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-28 23:20:47 +0200
commit4d84148a84abd331b7645b4de1b31621dec37615 (patch)
treead5e16309d2bd3002731624d725135a82cb90ef4 /dev-util/cmocka/cmocka-1.1.3.ebuild
parentdev-libs/libebml: Drop 1.3.6 and 1.3.7 (diff)
downloadgentoo-4d84148a84abd331b7645b4de1b31621dec37615.tar.gz
gentoo-4d84148a84abd331b7645b4de1b31621dec37615.tar.bz2
gentoo-4d84148a84abd331b7645b4de1b31621dec37615.zip
dev-util/cmocka: Drop 1.1.3
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-util/cmocka/cmocka-1.1.3.ebuild')
-rw-r--r--dev-util/cmocka/cmocka-1.1.3.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-util/cmocka/cmocka-1.1.3.ebuild b/dev-util/cmocka/cmocka-1.1.3.ebuild
deleted file mode 100644
index 59978fb7fdf0..000000000000
--- a/dev-util/cmocka/cmocka-1.1.3.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake-multilib
-
-DESCRIPTION="Unit testing framework for C"
-HOMEPAGE="https://cmocka.org/"
-SRC_URI="https://cmocka.org/files/1.1/${P}.tar.xz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="doc examples static-libs test"
-
-BDEPEND="
- doc? ( app-doc/doxygen[dot] )
-"
-
-DOCS=( AUTHORS ChangeLog README.md )
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-doxygen.patch" # bug 671404
- "${FILESDIR}/${P}-examples.patch"
-)
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DWITH_EXAMPLES=$(usex examples)
- -DWITH_STATIC_LIB=$(usex static-libs)
- -DUNIT_TESTING=$(usex test)
- $(multilib_is_native_abi && cmake-utils_use_find_package doc Doxygen \
- || echo -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON)
- )
-
- cmake-utils_src_configure
-}
-
-multilib_src_compile() {
- cmake-utils_src_compile
- multilib_is_native_abi && use doc && cmake-utils_src_compile docs
-}
-
-multilib_src_install() {
- if multilib_is_native_abi && use doc; then
- local HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
- fi
-
- cmake-utils_src_install
-}