summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-08-11 10:49:53 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-08-11 10:49:53 +0200
commitc78dddfa009b97b1d089fe743d43fb90d95f1deb (patch)
tree0058d0eb4e5a3f9c9e0a56086ca94d10851cfd78 /dev-util/cppcheck/cppcheck-9999.ebuild
parentdev-util/cppcheck: version bump to 1.84 (diff)
downloadgentoo-c78dddfa009b97b1d089fe743d43fb90d95f1deb.tar.gz
gentoo-c78dddfa009b97b1d089fe743d43fb90d95f1deb.tar.bz2
gentoo-c78dddfa009b97b1d089fe743d43fb90d95f1deb.zip
dev-util/cppcheck: Sync live with 1.84 changes
Package-Manager: Portage-2.3.45, Repoman-2.3.10
Diffstat (limited to 'dev-util/cppcheck/cppcheck-9999.ebuild')
-rw-r--r--dev-util/cppcheck/cppcheck-9999.ebuild30
1 files changed, 15 insertions, 15 deletions
diff --git a/dev-util/cppcheck/cppcheck-9999.ebuild b/dev-util/cppcheck/cppcheck-9999.ebuild
index 2ef2f6f37cad..dcbdddafe553 100644
--- a/dev-util/cppcheck/cppcheck-9999.ebuild
+++ b/dev-util/cppcheck/cppcheck-9999.ebuild
@@ -11,13 +11,13 @@ DESCRIPTION="static analyzer of C/C++ code"
HOMEPAGE="http://cppcheck.sourceforge.net"
EGIT_REPO_URI="https://github.com/danmar/cppcheck.git"
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
SLOT="0"
KEYWORDS=""
IUSE="htmlreport pcre qt5"
RDEPEND="
- >=dev-libs/tinyxml2-2
+ dev-libs/tinyxml2:=
htmlreport? ( dev-python/pygments[${PYTHON_USEDEP}] )
pcre? ( dev-libs/libpcre )
qt5? (
@@ -48,7 +48,7 @@ src_prepare() {
src_configure() {
if use pcre ; then
sed -e '/HAVE_RULES=/s:=no:=yes:' \
- -i Makefile
+ -i Makefile || die
fi
}
@@ -59,29 +59,29 @@ src_compile() {
DB2MAN="${EROOT}usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl"
if use qt5 ; then
- pushd gui
+ pushd gui || die
eqmake5
emake
- popd
+ popd || die
fi
if use htmlreport ; then
- pushd htmlreport
+ pushd htmlreport || die
distutils-r1_src_compile
- popd
+ popd || die
fi
}
src_test() {
# safe final version
- mv -v ${PN}{,.final}
- mv -v lib/library.o{,.final}
- mv -v cli/cppcheckexecutor.o{,.final}
+ mv -v ${PN}{,.final} || die
+ mv -v lib/library.o{,.final} || die
+ mv -v cli/cppcheckexecutor.o{,.final} || die
#trigger recompile with CFGDIR inside ${S}
emake check CFGDIR="${S}/cfg"
# restore
- mv -v ${PN}{.final,}
- mv -v lib/library.o{.final,}
- mv -v cli/cppcheckexecutor.o{.final,}
+ mv -v ${PN}{.final,} || die
+ mv -v lib/library.o{.final,} || die
+ mv -v cli/cppcheckexecutor.o{.final,} || die
}
src_install() {
@@ -95,9 +95,9 @@ src_install() {
dodoc gui/{projectfile.txt,gui.${PN}}
fi
if use htmlreport ; then
- pushd htmlreport
+ pushd htmlreport || die
distutils-r1_src_install
- popd
+ popd || die
find "${D}" -name "*.egg-info" -delete
else
rm "${ED}/usr/bin/cppcheck-htmlreport" || die