summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/lttng-modules
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/lttng-modules')
-rw-r--r--dev-util/lttng-modules/Manifest3
-rw-r--r--dev-util/lttng-modules/lttng-modules-2.5.0.ebuild44
-rw-r--r--dev-util/lttng-modules/lttng-modules-2.5.1.ebuild44
-rw-r--r--dev-util/lttng-modules/lttng-modules-2.6.0_rc1.ebuild44
-rw-r--r--dev-util/lttng-modules/metadata.xml12
5 files changed, 147 insertions, 0 deletions
diff --git a/dev-util/lttng-modules/Manifest b/dev-util/lttng-modules/Manifest
new file mode 100644
index 000000000000..58df523a2559
--- /dev/null
+++ b/dev-util/lttng-modules/Manifest
@@ -0,0 +1,3 @@
+DIST lttng-modules-2.5.0.tar.bz2 275319 SHA256 3dfa268024834a4598bbd356d2ae7ea1e2ad828c625943ea5f5ead484e8ad82b SHA512 c266d51af66958f25137db352e2df4497126afc4d448a226b1a03e422702e2aba8fed10ace68c50408ccdc99380f8cf4e85b44f08f9f1dd17efdb6f7d051ac0d WHIRLPOOL 87a21dd546342d8448ab1f7f4870c970d35133c1c1876b6d6147f50dd4ab8a86bd500fc6df208425a08348058d4e5f9da65f39ae481f54cdd268dcb7525f866c
+DIST lttng-modules-2.5.1.tar.bz2 277110 SHA256 962238175f0959ac71b97fdde144a3f76a84f63aea6b3645f94da88512bcccdb SHA512 f144710483660edd59e328fae89a72510a8e295aa29c3c7d6ff2da5900fe6d7f746970068e7a43c18ec6f987635563629c918471cdd7e2b2f6a2bc8fffdeefb4 WHIRLPOOL 29bd62f0b87c19f14278cc82c61c8c11c78a9c3fbd1548b7c2a6c9fae0c612849d00ff8acbb454389e8fa298cfad4bcbfefb5d001514be1b17bfa1f23ed754e3
+DIST lttng-modules-2.6.0-rc1.tar.bz2 295707 SHA256 5faf1a460b34235574c71acfb97ba93bce2e8b4b79c17735939d4cd849a4e439 SHA512 995544f9e966cfc7ba2a2e1d510d70eba4101117ea877e11597654768e2a2ec7f09c5ff2280a3d51a99b3b32918d5a3ff7e16d2e0de70cb5abe412a13a8f8a79 WHIRLPOOL 253ffb2f23db074a286a570bc2e9f66aa7e7198d0911565b472b122ed4d8b460c88ebfa62d35cfdf1b7aa19cdd8f8d5114004a4c0487cee42c7bc3d0836a0aec
diff --git a/dev-util/lttng-modules/lttng-modules-2.5.0.ebuild b/dev-util/lttng-modules/lttng-modules-2.5.0.ebuild
new file mode 100644
index 000000000000..14fd7addac85
--- /dev/null
+++ b/dev-util/lttng-modules/lttng-modules-2.5.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-mod
+
+MY_P="${P/_rc/-rc}"
+DESCRIPTION="LTTng Kernel Tracer Modules"
+HOMEPAGE="http://lttng.org"
+SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BUILD_TARGETS="default"
+
+CONFIG_CHECK="MODULES KALLSYMS HIGH_RES_TIMERS TRACEPOINTS
+ ~HAVE_SYSCALL_TRACEPOINTS ~PERF_EVENTS ~EVENT_TRACING ~KPROBES KRETPROBES"
+
+MODULE_NAMES="true"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ if kernel_is lt 2 6 27; then
+ eerror "${PN} require Linux kernel >= 2.6.27"
+ die "Please update your kernel!"
+ fi
+}
+
+src_install() {
+ for i in $(find "${S}" -name "*.ko" -print); do
+ local val=${i##${S}/}
+ local modules+="${val%%.ko}(misc:) "
+ done
+ MODULE_NAMES=${modules}
+
+ linux-mod_src_install
+ dodoc ChangeLog README TODO
+}
diff --git a/dev-util/lttng-modules/lttng-modules-2.5.1.ebuild b/dev-util/lttng-modules/lttng-modules-2.5.1.ebuild
new file mode 100644
index 000000000000..14fd7addac85
--- /dev/null
+++ b/dev-util/lttng-modules/lttng-modules-2.5.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-mod
+
+MY_P="${P/_rc/-rc}"
+DESCRIPTION="LTTng Kernel Tracer Modules"
+HOMEPAGE="http://lttng.org"
+SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BUILD_TARGETS="default"
+
+CONFIG_CHECK="MODULES KALLSYMS HIGH_RES_TIMERS TRACEPOINTS
+ ~HAVE_SYSCALL_TRACEPOINTS ~PERF_EVENTS ~EVENT_TRACING ~KPROBES KRETPROBES"
+
+MODULE_NAMES="true"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ if kernel_is lt 2 6 27; then
+ eerror "${PN} require Linux kernel >= 2.6.27"
+ die "Please update your kernel!"
+ fi
+}
+
+src_install() {
+ for i in $(find "${S}" -name "*.ko" -print); do
+ local val=${i##${S}/}
+ local modules+="${val%%.ko}(misc:) "
+ done
+ MODULE_NAMES=${modules}
+
+ linux-mod_src_install
+ dodoc ChangeLog README TODO
+}
diff --git a/dev-util/lttng-modules/lttng-modules-2.6.0_rc1.ebuild b/dev-util/lttng-modules/lttng-modules-2.6.0_rc1.ebuild
new file mode 100644
index 000000000000..048c6a77c95c
--- /dev/null
+++ b/dev-util/lttng-modules/lttng-modules-2.6.0_rc1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-mod
+
+MY_P="${P/_rc/-rc}"
+DESCRIPTION="LTTng Kernel Tracer Modules"
+HOMEPAGE="http://lttng.org"
+SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BUILD_TARGETS="default"
+
+CONFIG_CHECK="MODULES KALLSYMS HIGH_RES_TIMERS TRACEPOINTS
+ ~HAVE_SYSCALL_TRACEPOINTS ~PERF_EVENTS ~EVENT_TRACING ~KPROBES KRETPROBES"
+
+MODULE_NAMES="true"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ if kernel_is lt 2 6 27; then
+ eerror "${PN} require Linux kernel >= 2.6.27"
+ die "Please update your kernel!"
+ fi
+}
+
+src_install() {
+ for i in $(find "${S}" -name "*.ko" -print); do
+ local val=${i##${S}/}
+ local modules+="${val%%.ko}(misc:) "
+ done
+ MODULE_NAMES=${modules}
+
+ linux-mod_src_install
+ dodoc ChangeLog README.md TODO
+}
diff --git a/dev-util/lttng-modules/metadata.xml b/dev-util/lttng-modules/metadata.xml
new file mode 100644
index 000000000000..09cc9fe8072a
--- /dev/null
+++ b/dev-util/lttng-modules/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dlan@gentoo.org</email>
+ <name>Yixun Lan</name>
+ </maintainer>
+
+ <longdescription>
+ Use the kernel tracer if you are debugging a system-wide performance problem or a kernel problem. This tracer comes with an instrumentation patch for most kernel subsystems, which is enough to debug many problems. This includes system calls, IRQs, traps, memory management, softIRQs, scheduling and many others. Of course, the kernel tracer allows you to add your own instrumentation anywhere in the kernel code.
+ </longdescription>
+</pkgmetadata>