summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2018-08-25 19:37:42 +0200
committerMichael Weber <xmw@gentoo.org>2018-08-25 19:37:58 +0200
commitd8e87b11e45cb097805dc66558598b8aca381d35 (patch)
tree328be092859bdddbac0a659cc2dda81dcc854df5 /dev-util/lttng-modules
parentdev-util/lttng-tools: Version bump (diff)
downloadgentoo-d8e87b11e45cb097805dc66558598b8aca381d35.tar.gz
gentoo-d8e87b11e45cb097805dc66558598b8aca381d35.tar.bz2
gentoo-d8e87b11e45cb097805dc66558598b8aca381d35.zip
dev-util/lttng-modules: Version bump
- EAPI-7 versionator.class replacement Closes: https://bugs.gentoo.org/515302 Closes: https://bugs.gentoo.org/663822 Package-Manager: Portage-2.3.45, Repoman-2.3.10
Diffstat (limited to 'dev-util/lttng-modules')
-rw-r--r--dev-util/lttng-modules/Manifest1
-rw-r--r--dev-util/lttng-modules/lttng-modules-2.10.6.ebuild49
-rw-r--r--dev-util/lttng-modules/lttng-modules-2.8.0.ebuild6
3 files changed, 55 insertions, 1 deletions
diff --git a/dev-util/lttng-modules/Manifest b/dev-util/lttng-modules/Manifest
index 18c0fca586ef..a2a3abfc9189 100644
--- a/dev-util/lttng-modules/Manifest
+++ b/dev-util/lttng-modules/Manifest
@@ -1,3 +1,4 @@
+DIST lttng-modules-2.10.6.tar.bz2 302285 BLAKE2B 3a6ca46ce87d5d846f65f250a10951b1c72d305a817bd147d4e0c1896aafd2c81745253f2cd19069e0e59a46724009c4f0591926daaff43c9885019bbbc4bc8d SHA512 1bc5246f1d93201f2bce62e64d3773de70ad3aad9eb5b9bbe141dfba19e7a03f65ef738c1985f1de557c81383e1be2ce8af474c1f7593f63f4256b3fde5dd9b6
DIST lttng-modules-2.6.4.tar.bz2 295609 BLAKE2B dcc0d46c57b53abaf65f499a889d6fa32d062f47b589450d5d8d65f7a50b9870340ea8670fa69c8eaf86239c86a1f299db8378a562e3afc2b00d3a582dde9eae SHA512 ec93456829b04964d0c9befd1071e220bc047e3bf57978bf9e6a666d0be418c5825873746604e0758cd8fcd47f70f4471e0b190ad87f53b79d7efa94febeef03
DIST lttng-modules-2.7.1.tar.bz2 297555 BLAKE2B 910720692b8801efd0335963fe8fc504bc9cd08ad772be1418c63f5c3f8aaf8c25aa7d49e0503bd355da64a9441302f14eb0b1a58fc8e76e0c2770b1c4ecb256 SHA512 77609c7b7bc0a8315dd4c635c1be2d84cc1a946438323b362bd25cfcd97f2cf9655aefdbca8b96fceb61db7b733219251d2f9f2e1a46c7534c5d1c622c03b744
DIST lttng-modules-2.7.4.tar.bz2 302329 BLAKE2B 32526361d3814ff834b3dc152833f610f64189a573e171102b45ef730b5ade57e382f70bbce1a5b5462c7e18e04ac1157f404f2cae260e29a69aceff0a8ed956 SHA512 bdec56c59f282be9a7d191f7799db5b66577f231f92e8fffbc1dad059706fe07c4dd288e74b516e8f6c13cc0da8a54f5e5dd913ae39639489b8eb1507ede08a8
diff --git a/dev-util/lttng-modules/lttng-modules-2.10.6.ebuild b/dev-util/lttng-modules/lttng-modules-2.10.6.ebuild
new file mode 100644
index 000000000000..159621ef8ebe
--- /dev/null
+++ b/dev-util/lttng-modules/lttng-modules-2.10.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod
+
+MY_P="${P/_rc/-rc}"
+MY_SLOT="$(ver_cut 1-2)"
+
+DESCRIPTION="LTTng Kernel Tracer Modules"
+HOMEPAGE="http://lttng.org"
+SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${MY_SLOT}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BUILD_TARGETS="default"
+
+CONFIG_CHECK="MODULES KALLSYMS HIGH_RES_TIMERS TRACEPOINTS
+ ~HAVE_SYSCALL_TRACEPOINTS ~PERF_EVENTS ~EVENT_TRACING ~KPROBES KRETPROBES"
+
+MODULE_NAMES="true"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ if kernel_is lt 2 6 27; then
+ eerror "${PN} require Linux kernel >= 2.6.27"
+ die "Please update your kernel!"
+ fi
+}
+
+src_compile() {
+ BUILD_FIXES="KERNELDIR=$KERNEL_DIR" linux-mod_src_compile
+}
+
+src_install() {
+ for i in $(find "${S}" -name "*.ko" -print); do
+ local val=${i##${S}/}
+ local modules+="${val%%.ko}(misc:) "
+ done
+ MODULE_NAMES=${modules}
+
+ linux-mod_src_install
+ dodoc ChangeLog README.md TODO
+}
diff --git a/dev-util/lttng-modules/lttng-modules-2.8.0.ebuild b/dev-util/lttng-modules/lttng-modules-2.8.0.ebuild
index d7f32b7b99d1..33312ef7bf42 100644
--- a/dev-util/lttng-modules/lttng-modules-2.8.0.ebuild
+++ b/dev-util/lttng-modules/lttng-modules-2.8.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -33,6 +33,10 @@ pkg_pretend() {
fi
}
+src_compile() {
+ BUILD_FIXES="KERNELDIR=$KERNEL_DIR" linux-mod_src_compile
+}
+
src_install() {
for i in $(find "${S}" -name "*.ko" -print); do
local val=${i##${S}/}