summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2019-12-21 17:16:12 +0100
committerCédric Krier <cedk@gentoo.org>2019-12-21 17:16:12 +0100
commit273afeff1bcd9c271b67a0b5bf0110761fdb0aa0 (patch)
tree0c51c702fe6b518b09374d15b1a9af9d14437a04 /dev-util/stripe-mock/stripe-mock-0.78.0.ebuild
parentdev-python/simpleeval: Version bumps (diff)
downloadgentoo-273afeff1bcd9c271b67a0b5bf0110761fdb0aa0.tar.gz
gentoo-273afeff1bcd9c271b67a0b5bf0110761fdb0aa0.tar.bz2
gentoo-273afeff1bcd9c271b67a0b5bf0110761fdb0aa0.zip
dev-util/stripe-mock: Version bumps
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Cédric Krier <cedk@gentoo.org>
Diffstat (limited to 'dev-util/stripe-mock/stripe-mock-0.78.0.ebuild')
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.78.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/stripe-mock-0.78.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.78.0.ebuild
new file mode 100644
index 000000000000..e3231b8082cf
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.78.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_SRC="github.com/stripe/stripe-mock"
+EGO_PN=${EGO_SRC}/...
+inherit golang-build golang-vcs-snapshot
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+
+src_install() {
+ golang-build_src_install
+ dobin bin/stripe-mock
+ rm -rf "${D%/}$(get_golibdir_gopath)" || die
+}