summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-08-18 00:07:28 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-08-18 00:09:56 +0100
commit53cff1ba74a8d9c9b1bbc4824b6649228b1cc307 (patch)
tree39c23e152516be986ae1ee53015d50ac155ef907 /dev-util
parentkde-apps/krfb: Add missing slot operator (diff)
downloadgentoo-53cff1ba74a8d9c9b1bbc4824b6649228b1cc307.tar.gz
gentoo-53cff1ba74a8d9c9b1bbc4824b6649228b1cc307.tar.bz2
gentoo-53cff1ba74a8d9c9b1bbc4824b6649228b1cc307.zip
dev-util/ccache: bump up to 3.7.3
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ccache/Manifest1
-rw-r--r--dev-util/ccache/ccache-3.7.3.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-util/ccache/Manifest b/dev-util/ccache/Manifest
index 043c9706b7b2..2227ebfafaf1 100644
--- a/dev-util/ccache/Manifest
+++ b/dev-util/ccache/Manifest
@@ -2,3 +2,4 @@ DIST ccache-3.3.4.tar.xz 314468 BLAKE2B 6e465598df428979a2c821a698afef25c05d0904
DIST ccache-3.6.tar.xz 340608 BLAKE2B fa92180f53612f84b71c68da4acccefee129e5bfc9b269caa45a9c16219ed835ccf034d61ff938a54f3673fa23410d960475cc37cf5d27d7be641e7518a43f0a SHA512 13ce4c9084983ce77617cf005235987715cd6b630dac13a17cb9badce24aab71bff505e63da4206878e32d337cc674f05fbf78540711ec5b33a0b8384c47fa0d
DIST ccache-3.7.1.tar.xz 349276 BLAKE2B 4f36ccb378b614668777d8be32dd343a0e59e36885a845ba004082f7ca0f69a5e4d01ed08af445c33bff218d33ad0385ed6ade383c06da20e3d0271b2f7423dd SHA512 c2f369c861998f82600272deedc436840af7f85baa355a1e119dacea8f41275d601a0805c3e2a8bc434df621a4e52647bd8654a71c2329542a8b160f7f179cdf
DIST ccache-3.7.2.tar.xz 351168 BLAKE2B 6e5c8847f961bd5aa2cf325e582ece9e8bfb9c015fe3dcb01c8ca1e1834fdfb82a351ec49e203721486817df58c6aebf28e0af011f470fb739d5016f72191654 SHA512 3290f0609c27a2f063e632392be01ef163273115700f87a6d2954fcfd52fcc14bf66fc147ecbd2b692258317e113bf8be9f7efdf377560e2e8d9dd67cef58147
+DIST ccache-3.7.3.tar.xz 351416 BLAKE2B f825eea87e89246edecbbc0b02cd0f67bbb0e9eb082a4f0c3d9aadca14a20e2d8e9af5f2c067d78393ea92c11878a11423402160210f3f79a3135d345225e0ad SHA512 74e6dd9558273af74aaf085d932955e8ded3d9f7d7b316172109af8f703f00a75fcc27187469d9cb5ba8654bcad12e406bede77cfcacbc0a752d5ca42e52c628
diff --git a/dev-util/ccache/ccache-3.7.3.ebuild b/dev-util/ccache/ccache-3.7.3.ebuild
new file mode 100644
index 000000000000..f3a519ee73c5
--- /dev/null
+++ b/dev-util/ccache/ccache-3.7.3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="fast compiler cache"
+HOMEPAGE="https://ccache.dev/"
+SRC_URI="https://github.com/ccache/ccache/releases/download/v${PV}/ccache-${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+IUSE=""
+
+DEPEND="app-arch/xz-utils
+ sys-libs/zlib"
+RDEPEND="${DEPEND}
+ dev-util/shadowman
+ sys-apps/gentoo-functions"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.5-nvcc-test.patch
+)
+
+src_prepare() {
+ default
+
+ # make sure we always use system zlib
+ rm -rf src/zlib || die
+ sed \
+ -e "/^EPREFIX=/s:'':'${EPREFIX}':" \
+ "${FILESDIR}"/ccache-config-3 > ccache-config || die
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_test() {
+ emake check V=1
+}
+
+src_install() {
+ DOCS=( doc/{AUTHORS,MANUAL,NEWS}.adoc CONTRIBUTING.md README.md )
+ default
+
+ dobin ccache-config
+ insinto /usr/share/shadowman/tools
+ newins - ccache <<<'/usr/lib/ccache/bin'
+
+ DOC_CONTENTS="
+To use ccache with **non-Portage** C compiling, add
+'${EPREFIX}/usr/lib/ccache/bin' to the beginning of your path, before
+'${EPREFIX}/usr/bin'. Portage will automatically take advantage of ccache with
+no additional steps. If this is your first install of ccache, type
+something like this to set a maximum cache size of 2GB:\\n
+# ccache -M 2G\\n
+If you are upgrading from an older version than 3.x you should clear all of your caches like so:\\n
+# CCACHE_DIR='${CCACHE_DIR:-${PORTAGE_TMPDIR}/ccache}' ccache -C\\n
+ccache now supports sys-devel/clang and dev-lang/icc, too!"
+
+ readme.gentoo_create_doc
+}
+
+pkg_prerm() {
+ if [[ -z ${REPLACED_BY_VERSION} && ${ROOT:-/} == / ]] ; then
+ eselect compiler-shadow remove ccache
+ fi
+}
+
+pkg_postinst() {
+ if [[ ${ROOT:-/} == / ]]; then
+ eselect compiler-shadow update ccache
+ fi
+
+ # nuke broken symlinks from previous versions that shouldn't exist
+ rm -rf "${EROOT}"/usr/lib/ccache.backup || die
+
+ readme.gentoo_print_elog
+}