summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-04-18 07:57:35 -0400
committerAnthony G. Basile <blueness@gentoo.org>2019-04-18 07:57:52 -0400
commitbb3feea0779d45abc32ba737d347ea24e35badce (patch)
tree624a7d9af86459fc472c60245cf6707db75a4e25 /dev-util
parentnet-dns/libidn2: Drop unneeded dev-libs/gnulib dependency (diff)
downloadgentoo-bb3feea0779d45abc32ba737d347ea24e35badce.tar.gz
gentoo-bb3feea0779d45abc32ba737d347ea24e35badce.tar.bz2
gentoo-bb3feea0779d45abc32ba737d347ea24e35badce.zip
dev-util/valgrind: version bump to 3.15.0
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/valgrind/Manifest1
-rw-r--r--dev-util/valgrind/valgrind-3.15.0.ebuild118
2 files changed, 119 insertions, 0 deletions
diff --git a/dev-util/valgrind/Manifest b/dev-util/valgrind/Manifest
index c3d65f616f23..5d28ed6ed108 100644
--- a/dev-util/valgrind/Manifest
+++ b/dev-util/valgrind/Manifest
@@ -1,3 +1,4 @@
DIST valgrind-3.12.0.tar.bz2 12788556 BLAKE2B aeebf9c29afb3cce683c6448a3dec8f4edb1e44b2043a8e159c57a28c75fee49c5dba144d7ae2d79d23fe5a6c5b2bbf01fc398909bf12eebc027f8a7d4d83009 SHA512 2c083f7c2e74dc58600397726d9d3af7a2cea40fe3d8733149886d1d77867e6c09996e5be1c58dd932f3662acf7363e04eeadbc0f9c8f0dac089e605024229be
DIST valgrind-3.13.0.tar.bz2 14723076 BLAKE2B cdf92087575cc851d316e2136081441f528596048bc5d1e9c17539283085dd9accd0c1b3136f9768a62de27d1f1641b450305681a33d9ba9fdfe028a73c0cb99 SHA512 34e1013cd3815d30a459b86220e871bb0a6209cc9e87af968f347083693779f022e986f211bdf1a5184ad7370cde12ff2cfca8099967ff94732970bd04a97009
DIST valgrind-3.14.0.tar.bz2 16602858 BLAKE2B 00d601593388180cc874cf2f0c78e79f705f145e45ea82996117cb91ba881e7888ef241fb7e45927f82f99666d76ed35cb5d451e9a3ef123c04a0dff233b2269 SHA512 68e548c42df31dc2b883a403e0faff7480c49b3054841870f5d2f742141ba199eca5d83c96bbf283115f0633f2bdb0860161d422f98e3ec720ec65760d250f97
+DIST valgrind-3.15.0.tar.bz2 20241437 BLAKE2B a1bd46d46b3cd9f963773d011e7c74bf5e09e59be13afe38229a3c66a89eeb416498faed67d6ec21489b630b55ac73cc212e17ba515884f8b6374849a60e3720 SHA512 5695d1355226fb63b0c80809ed43bb077b6eed4d427792d9d7ed944c38b557a84fe3c783517b921e32f161228e10e4625bea0550faa4685872bb4454450cfa7f
diff --git a/dev-util/valgrind/valgrind-3.15.0.ebuild b/dev-util/valgrind/valgrind-3.15.0.ebuild
new file mode 100644
index 000000000000..b18a128859a5
--- /dev/null
+++ b/dev-util/valgrind/valgrind-3.15.0.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools flag-o-matic toolchain-funcs multilib pax-utils
+
+DESCRIPTION="An open-source memory debugger for GNU/Linux"
+HOMEPAGE="http://www.valgrind.org"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="mpi"
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://sourceware.org/git/${PN}.git/"
+ inherit git-r3
+else
+ SRC_URI="ftp://sourceware.org/pub/valgrind/${P}.tar.bz2"
+ KEYWORDS="-* ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
+fi
+
+DEPEND="mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Correct hard coded doc location
+ sed -i -e "s:doc/valgrind:doc/${PF}:" docs/Makefile.am || die
+
+ # Don't force multiarch stuff on OSX, bug #306467
+ sed -i -e 's:-arch \(i386\|x86_64\)::g' Makefile.all.am || die
+
+ # Respect CFLAGS, LDFLAGS
+ eapply "${FILESDIR}"/${PN}-3.7.0-respect-flags.patch
+
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ # upstream doesn't support this, but we don't build with
+ # Sun/Oracle ld, we have a GNU toolchain, so get some things
+ # working the Linux/GNU way
+ find "${S}" -name "Makefile.am" -o -name "Makefile.tool.am" | xargs \
+ sed -i -e 's:-M,/usr/lib/ld/map.noexstk:-z,noexecstack:' || die
+ cp "${S}"/coregrind/link_tool_exe_{linux,solaris}.in
+ fi
+
+ # Allow users to test their own patches
+ eapply_user
+
+ # Regenerate autotools files
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=()
+
+ # Respect ar, bug #468114
+ tc-export AR
+
+ # -fomit-frame-pointer "Assembler messages: Error: junk `8' after expression"
+ # while compiling insn_sse.c in none/tests/x86
+ # -fstack-protector more undefined references to __guard and __stack_smash_handler
+ # because valgrind doesn't link to glibc (bug #114347)
+ # -fstack-protector-all Fails same way as -fstack-protector/-fstack-protector-strong.
+ # Note: -fstack-protector-explicit is a no-op for Valgrind, no need to strip it
+ # -fstack-protector-strong See -fstack-protector (bug #620402)
+ # -m64 -mx32 for multilib-portage, bug #398825
+ # -ggdb3 segmentation fault on startup
+ filter-flags -fomit-frame-pointer
+ filter-flags -fstack-protector
+ filter-flags -fstack-protector-all
+ filter-flags -fstack-protector-strong
+ filter-flags -m64 -mx32
+ replace-flags -ggdb3 -ggdb2
+
+ if use amd64 || use ppc64; then
+ ! has_multilib_profile && myconf+=("--enable-only64bit")
+ fi
+
+ # Force bitness on darwin, bug #306467
+ use x86-macos && myconf+=("--enable-only32bit")
+ use x64-macos && myconf+=("--enable-only64bit")
+
+ # Don't use mpicc unless the user asked for it (bug #258832)
+ if ! use mpi; then
+ myconf+=("--without-mpicc")
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ if [[ ${PV} == "9999" ]]; then
+ # Otherwise FAQ.txt won't exist:
+ emake -C docs FAQ.txt
+ mv docs/FAQ.txt . || die "Couldn't move FAQ.txt"
+ fi
+
+ dodoc FAQ.txt
+
+ pax-mark m "${ED}"/usr/$(get_libdir)/valgrind/*-*-linux
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # fix install_names on shared libraries, can't turn them into bundles,
+ # as dyld won't load them any more then, bug #306467
+ local l
+ for l in "${ED}"/usr/lib/valgrind/*.so ; do
+ install_name_tool -id "${EPREFIX}"/usr/lib/valgrind/${l##*/} "${l}"
+ done
+ fi
+}
+
+pkg_postinst() {
+ elog "Valgrind will not work if glibc does not have debug symbols."
+ elog "To fix this you can add splitdebug to FEATURES in make.conf"
+ elog "and remerge glibc. See:"
+ elog "https://bugs.gentoo.org/show_bug.cgi?id=214065"
+ elog "https://bugs.gentoo.org/show_bug.cgi?id=274771"
+ elog "https://bugs.gentoo.org/show_bug.cgi?id=388703"
+}