summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-06-29 12:23:21 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-06-29 13:22:36 -0400
commitd8f263e503f54eb05f2c764ae443ea2e08e47366 (patch)
treeb1329df32144dfbcc7f4078b693296c16f349036 /dev-util
parentgames-emulation/mgba: update live for lua scripting support (diff)
downloadgentoo-d8f263e503f54eb05f2c764ae443ea2e08e47366.tar.gz
gentoo-d8f263e503f54eb05f2c764ae443ea2e08e47366.tar.bz2
gentoo-d8f263e503f54eb05f2c764ae443ea2e08e47366.zip
dev-util/mingw64-toolchain: fix build with musl and gcc:12
Closes: https://bugs.gentoo.org/855002 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/mingw64-toolchain/files/gcc-11.3.0-musl-calloc.patch33
-rw-r--r--dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0-r1.ebuild1
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/mingw64-toolchain/files/gcc-11.3.0-musl-calloc.patch b/dev-util/mingw64-toolchain/files/gcc-11.3.0-musl-calloc.patch
new file mode 100644
index 000000000000..71602df60cca
--- /dev/null
+++ b/dev-util/mingw64-toolchain/files/gcc-11.3.0-musl-calloc.patch
@@ -0,0 +1,33 @@
+https://bugs.gentoo.org/855002
+https://gcc.gnu.org/PR104799
+https://gcc.gnu.org/PR106102
+--- a/gcc/gcc/cp/mapper-client.cc
++++ b/gcc/gcc/cp/mapper-client.cc
+@@ -29,2 +29,3 @@
+ #define INCLUDE_MAP
++#include <pthread.h>
+ #include "system.h"
+--- a/gcc/gcc/cp/mapper-resolver.cc
++++ b/gcc/gcc/cp/mapper-resolver.cc
+@@ -27,2 +27,3 @@
+ #define INCLUDE_MAP
++#include <pthread.h>
+ #include "system.h"
+--- a/gcc/gcc/cp/module.cc
++++ b/gcc/gcc/cp/module.cc
+@@ -206,2 +206,3 @@
+ #define INCLUDE_VECTOR
++#include <pthread.h>
+ #include "system.h"
+--- a/gcc/libcc1/libcc1plugin.cc
++++ b/gcc/libcc1/libcc1plugin.cc
+@@ -19,2 +19,3 @@
+
++#include <pthread.h>
+ #include <cc1plugin-config.h>
+--- a/gcc/libcc1/libcp1plugin.cc
++++ b/gcc/libcc1/libcp1plugin.cc
+@@ -20,2 +20,3 @@
+
++#include <pthread.h>
+ #include <cc1plugin-config.h>
diff --git a/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0-r1.ebuild b/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0-r1.ebuild
index c0d573454f7f..c902601aa43c 100644
--- a/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0-r1.ebuild
+++ b/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0-r1.ebuild
@@ -44,6 +44,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/mingw64-runtime-10.0.0-tmp-files-clash.patch
"${FILESDIR}"/gcc-11.3.0-plugin-objdump.patch
+ "${FILESDIR}"/gcc-11.3.0-musl-calloc.patch
)
pkg_pretend() {