summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/cvsgraph
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/cvsgraph')
-rw-r--r--dev-vcs/cvsgraph/Manifest2
-rw-r--r--dev-vcs/cvsgraph/cvsgraph-1.6.1.ebuild41
-rw-r--r--dev-vcs/cvsgraph/cvsgraph-1.7.0.ebuild41
-rw-r--r--dev-vcs/cvsgraph/metadata.xml12
4 files changed, 96 insertions, 0 deletions
diff --git a/dev-vcs/cvsgraph/Manifest b/dev-vcs/cvsgraph/Manifest
new file mode 100644
index 000000000000..decffd2b5db4
--- /dev/null
+++ b/dev-vcs/cvsgraph/Manifest
@@ -0,0 +1,2 @@
+DIST cvsgraph-1.6.1.tar.gz 114337 SHA256 05cdbed36bb2dd37aa382fc7f4410caac20dcf9176a50e922551cdc965dbc60b SHA512 6548d43784cd6e2e85777e0158371c6332f96f72fc8d1827dcece8aa54d77139021586e468155ec003d371eaa7095cd57a5004a1ed76bc55db325c3899105e6b WHIRLPOOL bd12cafe2d3fe5436adbb508b689f3e7bea1b8dfbc7aa02974ba23bc6d4dc57fe2f1e9f07325924e0ee949709091362a821948cda9b4273197eaac6650694add
+DIST cvsgraph-1.7.0.tar.gz 202678 SHA256 74438faaefd325c7a8ed289ea5d1657befe1d1859d55f8fbbcc7452f4efd435f SHA512 b2a5bec073e7fbba2a2b1975bb4583c8fa87d29a985b7bcedcaf556c744b822ea5ff65b5ca3c4bd6da6bb6697f5e023a7ce35cf5084f2d59fdd15297790e7aab WHIRLPOOL 1ca604faf530c2d3820fcc0d1c9e2c6bee4c4582f1caf93c98facb4610892a2a7160c0378daf175479af3ece76f2f35c08c7aaeabdd78a00e1f1e52e1e579c74
diff --git a/dev-vcs/cvsgraph/cvsgraph-1.6.1.ebuild b/dev-vcs/cvsgraph/cvsgraph-1.6.1.ebuild
new file mode 100644
index 000000000000..f98ae29b596d
--- /dev/null
+++ b/dev-vcs/cvsgraph/cvsgraph-1.6.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="CVS/RCS repository grapher"
+HOMEPAGE="http://www.akhphd.au.dk/~bertho/cvsgraph"
+SRC_URI="http://www.akhphd.au.dk/~bertho/cvsgraph/release/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-alpha amd64 -ia64 ppc sparc x86"
+IUSE="gif jpeg nls png truetype zlib"
+
+DEPEND="media-libs/gd
+ zlib? ( sys-libs/zlib )
+ gif? ( media-libs/giflib )
+ png? ( media-libs/libpng )
+ jpeg? ( virtual/jpeg )
+ truetype? ( media-libs/freetype )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable gif) \
+ $(use_enable png) \
+ $(use_enable jpeg) \
+ $(use_enable truetype) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ dobin cvsgraph
+ insinto /etc
+ doins cvsgraph.conf
+ doman cvsgraph.1 cvsgraph.conf.5
+ dodoc ChangeLog README contrib/*.php3
+ docinto automatic_documentation ; dodoc contrib/automatic_documentation/*
+}
diff --git a/dev-vcs/cvsgraph/cvsgraph-1.7.0.ebuild b/dev-vcs/cvsgraph/cvsgraph-1.7.0.ebuild
new file mode 100644
index 000000000000..dbaf49b05e55
--- /dev/null
+++ b/dev-vcs/cvsgraph/cvsgraph-1.7.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="CVS/RCS repository grapher"
+HOMEPAGE="http://www.akhphd.au.dk/~bertho/cvsgraph"
+SRC_URI="http://www.akhphd.au.dk/~bertho/cvsgraph/release/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-alpha amd64 -ia64 ~ppc ~sparc x86"
+IUSE="gif jpeg nls png truetype zlib"
+
+DEPEND="media-libs/gd
+ zlib? ( sys-libs/zlib )
+ gif? ( media-libs/giflib )
+ png? ( media-libs/libpng )
+ jpeg? ( virtual/jpeg )
+ truetype? ( media-libs/freetype )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable gif) \
+ $(use_enable png) \
+ $(use_enable jpeg) \
+ $(use_enable truetype) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ dobin cvsgraph
+ insinto /etc
+ doins cvsgraph.conf
+ doman cvsgraph.1 cvsgraph.conf.5
+ dodoc ChangeLog README AUTHORS contrib/*.php
+ docinto automatic_documentation ; dodoc contrib/automatic_documentation/*
+}
diff --git a/dev-vcs/cvsgraph/metadata.xml b/dev-vcs/cvsgraph/metadata.xml
new file mode 100644
index 000000000000..1f00c0c93be5
--- /dev/null
+++ b/dev-vcs/cvsgraph/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cvs-utils</herd>
+ <longdescription lang="en">
+ CvsGraph is a utility to make a graphical representation of all
+ revisions and branches of a file in a CVS/RCS repository. It has been
+ inspired by the 'graph' option in WinCVS, but I could not find a
+ stand-alone version of this graph code. So, it was time to write one.
+ </longdescription>
+</pkgmetadata>
+