summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2020-07-09 21:53:57 +0800
committerYixun Lan <dlan@gentoo.org>2020-07-09 21:53:57 +0800
commit458db7809ba64ee3149a151400c5f8b3e2379a9c (patch)
tree71c64549cbbe2ee99f56f721b5a4ff7e8e466e64 /dev-vcs
parentapp-emulation/xen-tools: drop vulnerable (diff)
downloadgentoo-458db7809ba64ee3149a151400c5f8b3e2379a9c.tar.gz
gentoo-458db7809ba64ee3149a151400c5f8b3e2379a9c.tar.bz2
gentoo-458db7809ba64ee3149a151400c5f8b3e2379a9c.zip
dev-vcs/stgit: version bump, 0.23:
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/stgit/Manifest1
-rw-r--r--dev-vcs/stgit/stgit-0.23.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-vcs/stgit/Manifest b/dev-vcs/stgit/Manifest
index 4e9a21ee32f8..1ab2950fd257 100644
--- a/dev-vcs/stgit/Manifest
+++ b/dev-vcs/stgit/Manifest
@@ -1,2 +1,3 @@
DIST stgit-0.21.tar.gz 319605 BLAKE2B 92bb879d8b8804c8a1b2ca8038d010a0b5118970a4482d87d6bc295992849511c33acb46f376034af6609d42c0323d692bff0ea9bf217cc860e53915fb3c982e SHA512 394c2b30596819f1376bd7432be6923a8dad73f58f049022fe64d1520fd75418665af8069aac98843df051f7fbefbb367762ad4ba57f13bf747819035c7d63ee
DIST stgit-0.22.tar.gz 308815 BLAKE2B 46c6214012b8d6973273bec716b1ffdafde3ea17930da94de0f73e91e8753fc7ce1d890964c8fac1d32e6343f86e54057b732414fb187b5c9f50e2fa581e6321 SHA512 bfef074b952e01d9041a4ed5dfc6786c29ebb4b09a424ca09e9131ad21c418c4d79ec13eb908f5e8b015ebbc709aacb13824a1c9cad6d97e018a166b014c5e6f
+DIST stgit-0.23.tar.gz 303836 BLAKE2B 018e0caf74a3c449a71362e3694b2ddf030f5ee23e3212a98b378b7118bae9fd15d0e4ab2a2a746a12b34e46aa2edb86657a4a7125f3c5ca8aa0142fe3d73534 SHA512 b3c9b5c0833cb7e5137faf0df48af6a11b9508b994cdf55b587567d1c146fd4ae29e7beb6d1a34b3f87e5b3854af035dd7e5ca35338c20740e91da7b47c4568d
diff --git a/dev-vcs/stgit/stgit-0.23.ebuild b/dev-vcs/stgit/stgit-0.23.ebuild
new file mode 100644
index 000000000000..a700e23fc3bc
--- /dev/null
+++ b/dev-vcs/stgit/stgit-0.23.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Manage a stack of patches using GIT as a backend"
+HOMEPAGE="http://www.procode.org/stgit/"
+UPSTREAM_VER=
+[[ -n ${UPSTREAM_VER} ]] && \
+ UPSTREAM_PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${P}-upstream-patches-${UPSTREAM_VER}.tar.xz"
+
+SRC_URI="https://github.com/ctmarinas/stgit/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${UPSTREAM_PATCHSET_URI}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND=">=dev-vcs/git-1.6.3.3"
+
+# NOTE: It seems to be quite important which asciidoc version to use.
+# So keep an eye on it for the future.
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ dev-lang/perl
+ )"
+
+pkg_setup() {
+ if ! use doc; then
+ echo
+ ewarn "Manpages will not be built and installed."
+ ewarn "Enable the 'doc' useflag, if you want them."
+ echo
+ fi
+}
+
+python_prepare_all() {
+ # Upstream's patchset
+ [[ -n ${UPSTREAM_VER} ]] && \
+ eapply "${WORKDIR}"/patches-upstream
+
+ # this will be a noop, as we are working with a tarball,
+ # but throws git errors --> just get rid of it
+ echo "version=\"${PV}\"" > "${S}"/stgit/builtin_version.py
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+
+ # bug 526468
+ if use doc; then
+ emake DESTDIR="${D}" \
+ htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
+ mandir="${EPREFIX}/usr/share/man/" \
+ doc
+ fi
+}
+
+src_install() {
+ if use doc; then
+ emake DESTDIR="${D}" \
+ htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
+ mandir="${EPREFIX}/usr/share/man/" \
+ install-doc install-html
+ fi
+
+ distutils-r1_src_install
+
+ newbashcomp completion/stgit.bash 'stg'
+}