summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-10-08 13:35:15 +0200
committerPacho Ramos <pacho@gentoo.org>2016-10-08 13:35:15 +0200
commit54816ff161c5965171dac5bbd765757e63e064c7 (patch)
tree1358c2ffe7e16a2f5eb77f4da5b314ff5a7cfd03 /dev-vcs
parentRemove masked for removal package (diff)
downloadgentoo-54816ff161c5965171dac5bbd765757e63e064c7.tar.gz
gentoo-54816ff161c5965171dac5bbd765757e63e064c7.tar.bz2
gentoo-54816ff161c5965171dac5bbd765757e63e064c7.zip
Revert "Remove masked for removal package"
This reverts commit b1638ccb950f026b98e0787fbb88e67de8a28558.
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-deps/git-deps-9999.ebuild48
-rw-r--r--dev-vcs/git-deps/metadata.xml12
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-vcs/git-deps/git-deps-9999.ebuild b/dev-vcs/git-deps/git-deps-9999.ebuild
new file mode 100644
index 000000000000..0e5eb8a78dfd
--- /dev/null
+++ b/dev-vcs/git-deps/git-deps-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/aspiers/git-deps"
+EGIT_BRANCH=master
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils git-r3 python-single-r1
+
+DESCRIPTION="git commit dependency analysis tool"
+HOMEPAGE="https://github.com/aspiers/git-deps"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pygit2[${PYTHON_USEDEP}]
+ net-libs/nodejs
+ ${PYTHON_DEPS}
+ "
+DEPEND="${RDEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+HTML_DOCS="html/."
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ python_newscript git-deps.py git-deps
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "Notes regarding the '--serve' option:"
+ elog "Please run 'npm install browserify' once"
+ elog "Copy the html sources:"
+ elog "rsync -av ${EROOT}/usr/share/${PN}/html ~/git-deps-html"
+ elog "cd ~/git-deps-html"
+ elog "npm install"
+ elog "browserify -t coffeeify -d js/git-deps-graph.coffee -o js/bundle.js"
+}
diff --git a/dev-vcs/git-deps/metadata.xml b/dev-vcs/git-deps/metadata.xml
new file mode 100644
index 000000000000..80bc337a2b0b
--- /dev/null
+++ b/dev-vcs/git-deps/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>nicolasbock@gentoo.org</email>
+ <name>Nicolas Bock</name>
+ </maintainer>
+ <longdescription lang="en">
+ git-deps is a tool for performing automatic analysis of dependencies
+ between commits in a git repository.
+ </longdescription>
+</pkgmetadata>