summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-11-02 13:41:11 +0100
committerLars Wendler <polynomial-c@gentoo.org>2015-11-02 13:45:08 +0100
commitcf34e067491aa6d5b5d27a385af29fd532e6f6b2 (patch)
treea8101e9ba2bcc1957de108d988c20f7c6f363437 /dev-vcs
parentmedia-libs/freeverb3: 3.1.2_pre20151102 (diff)
downloadgentoo-cf34e067491aa6d5b5d27a385af29fd532e6f6b2.tar.gz
gentoo-cf34e067491aa6d5b5d27a385af29fd532e6f6b2.tar.bz2
gentoo-cf34e067491aa6d5b5d27a385af29fd532e6f6b2.zip
dev-vcs/mercurial: Bump to version 3.6
Package-Manager: portage-2.2.23 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/mercurial/Manifest1
-rw-r--r--dev-vcs/mercurial/mercurial-3.6.ebuild140
2 files changed, 141 insertions, 0 deletions
diff --git a/dev-vcs/mercurial/Manifest b/dev-vcs/mercurial/Manifest
index ac298865c57e..f576b866ac9a 100644
--- a/dev-vcs/mercurial/Manifest
+++ b/dev-vcs/mercurial/Manifest
@@ -3,3 +3,4 @@ DIST mercurial-3.3.3.tar.gz 4167447 SHA256 a445367f0dcbaf3a6279bfa743b364e729be0
DIST mercurial-3.4.2.tar.gz 4296407 SHA256 dcc90e4a8476149ecc8af13c08202860b4c9c987a94c4f3c18b28294b6fd8ecd SHA512 f5ef7064a1ac4189fe4db91fec283cdead257b132674d0869f075b80ba5707e0163e28f18545a9d867336ebc6b1cbb8bcf794b6881b8f23f6c067e68c7ae584b WHIRLPOOL db7389c92680f6058efda6fa4cb7747ff3cd78bc361c43464a938c213b9ce46e8a040a57c68975f02342beb35522c27c3ab6250b2fc6e54777ddd20b0bda5443
DIST mercurial-3.5.1.tar.gz 4414284 SHA256 997da45da303e399678c5bccd7be39b0fabf29c7e02fd3c8751c2ff88c8a259d SHA512 2435b3c50753e787577a847c96d3e4515015e02bc7ecdd21848530834d210831bb0690d31d4940626bbbe84cfccb1d245f8c4e1156317cda9469e7b870c042d5 WHIRLPOOL 97a0e6762657c2f560041f30e513fe8d5377bf654e39bf8a218d132952f60b59db63a6c078cdac6b529a8cb49ee766054daad9192951987b3a288e3b43e70ba7
DIST mercurial-3.5.2.tar.gz 4415307 SHA256 23fdc038503911b21dc9e556118803f7b1d4150eb14933d2ea3d0ff0dc60ab5d SHA512 d0a4007763186ab72e7ef6e6f6fa84719fcdc2d16208bc99cc32f44cecdc0ccdf5719e18fbc8a5d0735f6441acc0d82bcac05d7c75fee15966c88ee75e7b6bdd WHIRLPOOL 10ec5dd3d1d2e3487f4a290bc0d32fe2237cc450b54774503e7e9e25b12e895c8065f1c2e27dcaa03deac82d1e10e58dd8ea18e9bacf4f24f58a52a3d5c0fea4
+DIST mercurial-3.6.tar.gz 4516703 SHA256 85b5574f3694373e981926374a758dab2128d6f3c593a72a7c9d2cb371054f39 SHA512 5e3fa99f6cb5a4f5867233946714222c53f05d95b791fd0855afc9d5f3dfade8aeae08b3581ea700ae64516f304a120843b4187d1e309c5cf0c15af798889664 WHIRLPOOL 732a938ff2d5064619d55da84f1c718ac149a9236e9631054c9852b359c80e5420f0b020641a2d0d35c32ca4b5771693c0537313b240f80f275aa6b24fc70ccd
diff --git a/dev-vcs/mercurial/mercurial-3.6.ebuild b/dev-vcs/mercurial/mercurial-3.6.ebuild
new file mode 100644
index 000000000000..1f57c1ef8c43
--- /dev/null
+++ b/dev-vcs/mercurial/mercurial-3.6.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+inherit bash-completion-r1 elisp-common eutils distutils-r1 flag-o-matic
+
+DESCRIPTION="Scalable distributed SCM"
+HOMEPAGE="http://mercurial.selenic.com/"
+SRC_URI="http://mercurial.selenic.com/release/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="bugzilla emacs gpg test tk"
+
+RDEPEND="bugzilla? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
+ gpg? ( app-crypt/gnupg )
+ tk? ( dev-lang/tk )
+ app-misc/ca-certificates"
+DEPEND="emacs? ( virtual/emacs )
+ test? ( app-arch/unzip
+ dev-python/pygments[${PYTHON_USEDEP}] )"
+
+SITEFILE="70${PN}-gentoo.el"
+
+PATCHES=( "${FILESDIR}/${PN}-3.0.1-po_fixes.patch" )
+
+python_prepare_all() {
+ # fix up logic that won't work in Gentoo Prefix (also won't outside in
+ # certain cases), bug #362891
+ sed -i -e 's:xcodebuild:nocodebuild:' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ strip-flags -ftracer -ftree-vectorize
+ # Note: make it impl-conditional if py3 is supported
+ append-flags -fno-strict-aliasing
+
+ "${PYTHON}" setup.py build_mo || die
+}
+
+python_compile_all() {
+ rm -r contrib/{win32,macosx} || die
+ if use emacs; then
+ cd contrib || die
+ elisp-compile mercurial.el || die "elisp-compile failed!"
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ newbashcomp contrib/bash_completion hg
+
+ insinto /usr/share/zsh/site-functions
+ newins contrib/zsh_completion _hg
+
+ rm -f doc/*.?.txt
+ dodoc CONTRIBUTORS
+ cp hgweb*.cgi "${ED}"/usr/share/doc/${PF}/ || die
+
+ dobin hgeditor
+ dobin contrib/hgk
+ python_foreach_impl python_doscript contrib/hg-ssh
+
+ if use emacs; then
+ elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ fi
+
+ local RM_CONTRIB=(hgk hg-ssh bash_completion zsh_completion wix buildrpm plan9
+ *.el mercurial.spec)
+ for f in ${RM_CONTRIB[@]}; do
+ rm -r contrib/$f || die
+ done
+
+ dodoc -r contrib
+ docompress -x /usr/share/doc/${PF}/contrib
+ doman doc/*.?
+
+ cat > "${T}/80mercurial" <<-EOF
+HG="${EPREFIX}/usr/bin/hg"
+EOF
+ doenvd "${T}/80mercurial"
+
+ insinto /etc/mercurial/hgrc.d
+ doins "${FILESDIR}/cacerts.rc"
+}
+
+src_test() {
+ pushd tests &>/dev/null || die
+ rm -rf *svn* # Subversion tests fail with 1.5
+ rm -f test-archive* # Fails due to verbose tar output changes
+ rm -f test-convert-baz* # GNU Arch baz
+ rm -f test-convert-cvs* # CVS
+ rm -f test-convert-darcs* # Darcs
+ rm -f test-convert-git* # git
+ rm -f test-convert-mtn* # monotone
+ rm -f test-convert-tla* # GNU Arch tla
+ #rm -f test-doctest* # doctest always fails with python 2.5.x
+ rm -f test-largefiles* # tends to time out
+
+ popd &>/dev/null || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ local TEST_DIR
+
+ rm -rf "${TMPDIR}"/test
+ distutils_install_for_testing
+ cd tests || die
+ "${PYTHON}" run-tests.py --verbose \
+ --tmpdir="${TMPDIR}"/test \
+ --with-hg="${TEST_DIR}"/scripts/hg \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+
+ elog "If you want to convert repositories from other tools using convert"
+ elog "extension please install correct tool:"
+ elog " dev-vcs/cvs"
+ elog " dev-vcs/darcs"
+ elog " dev-vcs/git"
+ elog " dev-vcs/monotone"
+ elog " dev-vcs/subversion"
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}