summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-03-31 04:46:18 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2016-03-31 04:46:34 -0400
commit5447acb2b36c8c75a5faee7908778fc916547409 (patch)
tree58def7f84d4c5540ef5ad8679a50d097de969927 /games-action/koth
parentdev-python/werkzeug: Bump (diff)
downloadgentoo-5447acb2b36c8c75a5faee7908778fc916547409.tar.gz
gentoo-5447acb2b36c8c75a5faee7908778fc916547409.tar.bz2
gentoo-5447acb2b36c8c75a5faee7908778fc916547409.zip
games-action/koth: build with gcc5 (bug #570730)
Package-Manager: portage-2.2.26
Diffstat (limited to 'games-action/koth')
-rw-r--r--games-action/koth/koth-0.8.0.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/games-action/koth/koth-0.8.0.ebuild b/games-action/koth/koth-0.8.0.ebuild
index 0bbe48f16ffa..eea7122cf3da 100644
--- a/games-action/koth/koth-0.8.0.ebuild
+++ b/games-action/koth/koth-0.8.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit eutils games
+inherit eutils flag-o-matic games
DESCRIPTION="Multiplayer, networked game of little tanks with really big weapons"
HOMEPAGE="http://www.nongnu.org/koth/"
@@ -23,6 +23,7 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-gcc-3.4.patch
sed -i "s:/etc/koth:${GAMES_SYSCONFDIR}:" cfgfile.h || die
sed -i 's:(uint16):(uint16_t):' gfx.c gfx.h || die
+ append-cflags -std=gnu89 # build with gcc5 (bug #570730)
}
src_install() {