summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2017-01-25 16:33:29 -0600
committerAustin English <wizardedit@gentoo.org>2017-01-25 17:05:07 -0600
commit6c313638c04a22706d4a66ba90bfbb79834cb21e (patch)
tree24e6cbfbdcc79874fbcd4d778f2319f1ce2990b9 /games-action/mutantstorm-demo
parentgames-action/koth: remove deprecated games eclass (diff)
downloadgentoo-6c313638c04a22706d4a66ba90bfbb79834cb21e.tar.gz
gentoo-6c313638c04a22706d4a66ba90bfbb79834cb21e.tar.bz2
gentoo-6c313638c04a22706d4a66ba90bfbb79834cb21e.zip
games-action/mutantstorm-demo: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: Portage-2.3.2, Repoman-2.3.1
Diffstat (limited to 'games-action/mutantstorm-demo')
-rw-r--r--games-action/mutantstorm-demo/mutantstorm-demo-1.33-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/games-action/mutantstorm-demo/mutantstorm-demo-1.33-r1.ebuild b/games-action/mutantstorm-demo/mutantstorm-demo-1.33-r1.ebuild
new file mode 100644
index 000000000000..cbb97a6430c2
--- /dev/null
+++ b/games-action/mutantstorm-demo/mutantstorm-demo-1.33-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils unpacker
+
+DESCRIPTION="shoot through crazy psychedelic 3D environments"
+HOMEPAGE="http://www.pompomgames.com/"
+SRC_URI="ftp://ggdev-1.homelan.com/mutantstorm/MutantStormDemo_${PV/./_}.sh.bin"
+
+LICENSE="POMPOM"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="strip"
+
+RDEPEND="
+ media-libs/libsdl[abi_x86_32(-)]
+ sys-libs/lib-compat
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]"
+
+S=${WORKDIR}
+
+dir=/opt/${PN}
+Ddir=${D}/${dir}
+QA_PREBUILT="${dir:1}/mutantstorm-bin"
+
+src_install() {
+ insinto "${dir}"
+ doins -r menu script styles
+
+ exeinto "${dir}"
+ doexe bin/Linux/x86/*
+ # Remove libSDL since we use the system version and our version doesn't
+ # have TEXTRELs in it.
+ rm -f "${Ddir}"/libSDL-1.2.so.0.0.5
+ make_wrapper mutantstorm-demo ./mutantstormdemo "${dir}" "${dir}"
+
+ insinto "${dir}"
+ doins README.txt buy_me mutant.xpm pompom readme.htm
+}