summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-16 22:03:32 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-16 22:26:34 +0200
commitf67fc6c86a3923599412c73a2eed05ba35022f58 (patch)
treeebd7f3659a7151e6debd569b66cc9d7f7efe3f2f /games-arcade/gav
parentgames-arcade/gav: Stop using games.eclass (diff)
downloadgentoo-f67fc6c86a3923599412c73a2eed05ba35022f58.tar.gz
gentoo-f67fc6c86a3923599412c73a2eed05ba35022f58.tar.bz2
gentoo-f67fc6c86a3923599412c73a2eed05ba35022f58.zip
games-arcade/gav: Drop old
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'games-arcade/gav')
-rw-r--r--games-arcade/gav/gav-0.9.0.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/games-arcade/gav/gav-0.9.0.ebuild b/games-arcade/gav/gav-0.9.0.ebuild
deleted file mode 100644
index 058dbaf64bc1..000000000000
--- a/games-arcade/gav/gav-0.9.0.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils games
-
-DESCRIPTION="GPL Arcade Volleyball"
-HOMEPAGE="http://gav.sourceforge.net/"
-# the themes are behind a lame php-counter script.
-SRC_URI="mirror://sourceforge/gav/${P}.tar.gz
- mirror://gentoo/fabeach.tgz
- mirror://gentoo/florindo.tgz
- mirror://gentoo/inverted.tgz
- mirror://gentoo/naive.tgz
- mirror://gentoo/unnamed.tgz
- mirror://gentoo/yisus.tgz
- mirror://gentoo/yisus2.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND="media-libs/sdl-image[jpeg,png]
- media-libs/sdl-net
- media-libs/libsdl[joystick,video]"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- local d
-
- epatch "${FILESDIR}"/${P}-ldflags.patch
-
- for d in . automa menu net ; do
- cp ${d}/Makefile.Linux ${d}/Makefile || die "cp ${d}/Makefile failed"
- done
-
- epatch "${FILESDIR}"/${P}-gcc43.patch
- sed -i \
- -e "s:/usr/bin:${GAMES_BINDIR}:" \
- Makefile \
- || die "sed failed"
- sed -i \
- -e "/^CXXFLAGS=/s: -g : ${CXXFLAGS} :" CommonHeader \
- || die "sed failed"
-
- # Now, move the additional themes in the proper directory
- mv ../{fabeach,florindo,inverted,naive,unnamed,yisus,yisus2} themes
-
- # no reason to have executable files in the themes
- find themes -type f -exec chmod a-x \{\} \;
-}
-
-src_compile() {
- # bug #41530 - doesn't like the hot parallel make action.
- emake -C automa
- emake -C menu
- emake -C net
- emake
-}
-
-src_install() {
- dodir "${GAMES_BINDIR}"
- emake ROOT="${D}" install
- insinto "${GAMES_DATADIR}"/${PN}
- doins -r sounds
- dodoc CHANGELOG README
- prepgamesdirs
-}