summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/spout
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/spout')
-rw-r--r--games-arcade/spout/Manifest1
-rw-r--r--games-arcade/spout/metadata.xml8
-rw-r--r--games-arcade/spout/spout-1.3.ebuild44
3 files changed, 53 insertions, 0 deletions
diff --git a/games-arcade/spout/Manifest b/games-arcade/spout/Manifest
new file mode 100644
index 000000000000..be33c8a9ff39
--- /dev/null
+++ b/games-arcade/spout/Manifest
@@ -0,0 +1 @@
+DIST spout-unix-1.3.tar.bz2 92144 SHA256 9b113230c6b6e8cc8148139a65ceef5bb43d27cbe66cf2139c5b13d33251c7bc SHA512 46ed12a617a4084e8a5d1da56799fe7784ed288a254385b109ced6138ce904e658a44af445c1577112a3701a0b108fc886e3d06df41743b0d82b028eb8a846d6 WHIRLPOOL 849758e71418c1dd3ea2a1450fea2b484f343c1a8d1f819fc181fe1fb7a0d571e785f61aa48734b53d817c8a1989740e1df82bfbdaa73fd590649c8753e6bea6
diff --git a/games-arcade/spout/metadata.xml b/games-arcade/spout/metadata.xml
new file mode 100644
index 000000000000..4f84a5e80d56
--- /dev/null
+++ b/games-arcade/spout/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="freshmeat">spout</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-arcade/spout/spout-1.3.ebuild b/games-arcade/spout/spout-1.3.ebuild
new file mode 100644
index 000000000000..051c3f4ed7b8
--- /dev/null
+++ b/games-arcade/spout/spout-1.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+MY_P="spout-unix-${PV}"
+DESCRIPTION="Abstract Japanese caveflier / shooter"
+HOMEPAGE="http://freshmeat.net/projects/spout/"
+SRC_URI="http://rohanpm.net/files/old/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="ppc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.2.6"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ dogamesbin spout
+ doicon spout.png
+ make_desktop_entry spout "Spout"
+ dodoc README
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "To play in fullscreen mode, do 'spout f'."
+ elog "To play in a greater resolution, do 'spout x', where"
+ elog "x is an integer; the larger x is, the higher the resolution."
+ echo
+ elog "To play:"
+ elog "Accelerate - spacebar, enter, z, x"
+ elog "Pause - escape"
+ elog "Exit - shift+escape"
+ elog "Rotate - left or right"
+ echo
+}