summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2017-01-21 19:01:32 +0100
committerSebastian Pipping <sping@gentoo.org>2017-01-21 21:35:30 +0100
commit26e178e8801e421b07830ab43d2c2d101e8bea5a (patch)
treef98698a03a6f99c3bafc8e255b88ef69f8db6918 /games-arcade
parentdev-python/attrs: ppc stable wrt bug #606330 (diff)
downloadgentoo-26e178e8801e421b07830ab43d2c2d101e8bea5a.tar.gz
gentoo-26e178e8801e421b07830ab43d2c2d101e8bea5a.tar.bz2
gentoo-26e178e8801e421b07830ab43d2c2d101e8bea5a.zip
games-arcade/blobby: 1.0 (bug #468766)
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/blobby/Manifest1
-rw-r--r--games-arcade/blobby/blobby-1.0.ebuild38
-rw-r--r--games-arcade/blobby/files/blobby-1.0-compile.patch29
-rw-r--r--games-arcade/blobby/files/blobby-1.0-install.patch29
-rw-r--r--games-arcade/blobby/files/blobby-1.0-paths.patch37
5 files changed, 134 insertions, 0 deletions
diff --git a/games-arcade/blobby/Manifest b/games-arcade/blobby/Manifest
index 6ddf0d43217a..971d4be4683f 100644
--- a/games-arcade/blobby/Manifest
+++ b/games-arcade/blobby/Manifest
@@ -1 +1,2 @@
DIST blobby2-linux-0.9c.tar.gz 2290384 SHA256 e3ed8f92c70e16d24f109b6f0f4dccc25656a88780eb1a348d1223edcb7fc937 SHA512 741eed708f6688af179e19cecc17cb1e0cdbd6a9e2680fbfd8093ca171c0593474ec1bd11c1704e6e275ae8693c72c8f2f93fdc9ec7863dcda5999a76b0002e2 WHIRLPOOL 04e5b7786290cd43abcfd25099c9dd338a4405e5fd8c796c366b6a8e456bbcc2930a906a8a4c6cb796aacf9f4716f3913b70f7ccdc35b025c0e924a30ccc4f63
+DIST blobby2-linux-1.0.tar.gz 1772918 SHA256 ba7a049e298aaa2014c1e1ac1faf3b0256b4c66266cd4db06e7939e8695bf5e2 SHA512 b9e36de4a44e482c9d0742b95034c2979d7a51512ac5e3fd8f4933655132028dfc9642c3580e5523b5b95d38acc169932d24808cee236710731c2571321337fa WHIRLPOOL 6442450293d3999cd085cc4681786573d082220cd3025d76a479e652ca51807ea7cc70faa4df97bae621c183ae46a14a23d1c714cd64972fbbee3c6b784ac6dc
diff --git a/games-arcade/blobby/blobby-1.0.ebuild b/games-arcade/blobby/blobby-1.0.ebuild
new file mode 100644
index 000000000000..bbc43bc519a9
--- /dev/null
+++ b/games-arcade/blobby/blobby-1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils cmake-utils
+
+DESCRIPTION="A beach ball game with blobs of goo"
+HOMEPAGE="https://sourceforge.net/projects/blobby/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}2-linux-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-games/physfs-2[zip]
+ media-libs/libsdl[sound,joystick,opengl,video,X]
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ virtual/pkgconfig
+ app-arch/zip" #406667
+
+DOCS=( AUTHORS ChangeLog README TODO )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-compile.patch
+ "${FILESDIR}"/${P}-paths.patch
+ "${FILESDIR}"/${P}-install.patch
+)
+
+src_install() {
+ cmake-utils_src_install
+
+ newicon data/Icon.bmp ${PN}.bmp
+ make_desktop_entry ${PN} "Blobby Volley" /usr/share/pixmaps/${PN}.bmp
+}
diff --git a/games-arcade/blobby/files/blobby-1.0-compile.patch b/games-arcade/blobby/files/blobby-1.0-compile.patch
new file mode 100644
index 000000000000..f41601d56375
--- /dev/null
+++ b/games-arcade/blobby/files/blobby-1.0-compile.patch
@@ -0,0 +1,29 @@
+From eaa17d2ad90de2024fc3a7a59575597d1dc0b171 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Sat, 21 Jan 2017 18:01:14 +0100
+Subject: [PATCH] Fix compilation
+
+---
+ src/NetworkMessage.cpp | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/src/NetworkMessage.cpp b/src/NetworkMessage.cpp
+index 9178e74..0c3163b 100644
+--- a/src/NetworkMessage.cpp
++++ b/src/NetworkMessage.cpp
+@@ -109,6 +109,11 @@ bool operator == (const ServerInfo& lval, const ServerInfo& rval)
+
+ std::ostream& operator<<(std::ostream& stream, const ServerInfo& val)
+ {
+- return stream << val.name << " (" << val.hostname << ":" << val.port << ")";
++ return stream
++ << std::string(val.name)
++ << std::string(" (")
++ << std::string(val.hostname)
++ << std::string(":") << std::to_string(val.port)
++ << std::string(")");
+ }
+
+--
+2.11.0
+
diff --git a/games-arcade/blobby/files/blobby-1.0-install.patch b/games-arcade/blobby/files/blobby-1.0-install.patch
new file mode 100644
index 000000000000..5bd95c121ed9
--- /dev/null
+++ b/games-arcade/blobby/files/blobby-1.0-install.patch
@@ -0,0 +1,29 @@
+From 0a3ebb368242ed379f4ff7d5eca24be79841d968 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Sat, 21 Jan 2017 18:55:47 +0100
+Subject: [PATCH] Install missing files
+
+---
+ data/CMakeLists.txt | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
+index a2454cd..5a2a661 100644
+--- a/data/CMakeLists.txt
++++ b/data/CMakeLists.txt
+@@ -25,10 +25,12 @@ set(install_files
+ ${CMAKE_CURRENT_BINARY_DIR}/backgrounds.zip
+ ${CMAKE_CURRENT_BINARY_DIR}/rules.zip
+ config.xml
++ Icon.bmp
+ inputconfig.xml
+ server/server.xml
+ lang_de.xml
+ lang_en.xml
++ lang_it.xml
+ lang_fr.xml)
+
+ if (WIN32)
+--
+2.11.0
+
diff --git a/games-arcade/blobby/files/blobby-1.0-paths.patch b/games-arcade/blobby/files/blobby-1.0-paths.patch
new file mode 100644
index 000000000000..6ddc76877e7d
--- /dev/null
+++ b/games-arcade/blobby/files/blobby-1.0-paths.patch
@@ -0,0 +1,37 @@
+From 3dbc91fcfe5412598201e33de80db7b1b01e4ffb Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Sat, 21 Jan 2017 18:49:04 +0100
+Subject: [PATCH] Use system installation path
+
+---
+ data/CMakeLists.txt | 2 +-
+ src/main.cpp | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
+index d9029b3..a2454cd 100644
+--- a/data/CMakeLists.txt
++++ b/data/CMakeLists.txt
+@@ -34,5 +34,5 @@ set(install_files
+ if (WIN32)
+ install(FILES ${install_files} DESTINATION data)
+ elseif (UNIX)
+- install(FILES ${install_files} DESTINATION share/blobby)
++ install(FILES ${install_files} DESTINATION /usr/share/blobby)
+ endif (WIN32)
+diff --git a/src/main.cpp b/src/main.cpp
+index 2628990..15bddf2 100644
+--- a/src/main.cpp
++++ b/src/main.cpp
+@@ -78,7 +78,7 @@ void setupPHYSFS()
+ std::string separator = fs.getDirSeparator();
+ // Game should be playable out of the source package on all
+ // relevant platforms.
+- std::string baseSearchPath("data" + separator);
++ std::string baseSearchPath("/usr/share/blobby/");
+ // Android and iOS are needing a special path
+ #ifdef __ANDROID__
+ baseSearchPath = SDL_AndroidGetExternalStoragePath() + separator;
+--
+2.11.0
+