summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/chessx
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/chessx')
-rw-r--r--games-board/chessx/Manifest1
-rw-r--r--games-board/chessx/chessx-1.3.2.ebuild42
-rw-r--r--games-board/chessx/files/chessx-1.3.2-zlib.patch35
-rw-r--r--games-board/chessx/metadata.xml5
4 files changed, 83 insertions, 0 deletions
diff --git a/games-board/chessx/Manifest b/games-board/chessx/Manifest
new file mode 100644
index 000000000000..b9ac41784c22
--- /dev/null
+++ b/games-board/chessx/Manifest
@@ -0,0 +1 @@
+DIST chessx-1.3.2.tgz 4107133 SHA256 b136cf56d37d34867cdb9538176e1703b14f61b3384885b6f100580d0af0a3ff SHA512 a8047b240e793323876615c9d83711a2b28a3855f4e0be9a1823d6a86f9d5155d001c9e44c9ddc2d2da5b87d6c4f2583cfcb49ed96aa7341dca2dceaec6f4e8f WHIRLPOOL 2fcc8dc2f89457b4a7f55cadf70e6b0c4267215e916f0acbaf85135c5240bc34bce207f4e697be7a69c3f0bcab721d0c12c15f4bf07841fc0dcf65e0ce16fefd
diff --git a/games-board/chessx/chessx-1.3.2.ebuild b/games-board/chessx/chessx-1.3.2.ebuild
new file mode 100644
index 000000000000..1a94d16a4ba7
--- /dev/null
+++ b/games-board/chessx/chessx-1.3.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils qmake-utils games
+
+DESCRIPTION="Qt5-based Chess Database Utility"
+HOMEPAGE="http://chessx.sourceforge.net/"
+SRC_URI="http://sourceforge.net/projects/chessx/files/chessx/${PV}/${P}.tgz"
+
+LICENSE="GPL-2+ LGPL-2+ LGPL-2.1+ ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-qt/qtprintsupport:5
+ dev-qt/qtsvg:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtxml:5
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-zlib.patch
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ dogamesbin release/${PN}
+ dodoc ChangeLog TODO
+ doicon data/images/${PN}.png
+ domenu unix/chessx.desktop
+ prepgamesdirs
+}
diff --git a/games-board/chessx/files/chessx-1.3.2-zlib.patch b/games-board/chessx/files/chessx-1.3.2-zlib.patch
new file mode 100644
index 000000000000..36d685d9cba9
--- /dev/null
+++ b/games-board/chessx/files/chessx-1.3.2-zlib.patch
@@ -0,0 +1,35 @@
+--- chessx-1.2.2/src/quazip/ioapi.h
++++ chessx-1.2.2-patched/src/quazip/ioapi.h
+@@ -1,3 +1,4 @@
++#define OF(x) x
+ /* ioapi.h -- IO base function header for compress/uncompress .zip
+ files using zlib + zip or unzip API
+
+--- chessx-1.2.2/src/quazip/unzip.c
++++ chessx-1.2.2-patched/src/quazip/unzip.c
+@@ -1,3 +1,4 @@
++#define OF(x) x
+ /* unzip.c -- IO for uncompress .zip files using zlib
+ Version 1.01e, February 12th, 2005
+
+--- chessx-1.2.2/src/quazip/unzip.h
++++ chessx-1.2.2-patched/src/quazip/unzip.h
+@@ -1,3 +1,4 @@
++#define OF(x) x
+ /* unzip.h -- IO for uncompress .zip files using zlib
+ Version 1.01e, February 12th, 2005
+
+--- chessx-1.2.2/src/quazip/zip.c
++++ chessx-1.2.2-patched/src/quazip/zip.c
+@@ -1,3 +1,4 @@
++#define OF(x) x
+ /* zip.c -- IO on .zip files using zlib
+ Version 1.01e, February 12th, 2005
+
+--- chessx-1.2.2/src/quazip/zip.h
++++ chessx-1.2.2-patched/src/quazip/zip.h
+@@ -1,3 +1,4 @@
++#define OF(x) x
+ /* zip.h -- IO for compress .zip files using zlib
+ Version 1.01e, February 12th, 2005
+
diff --git a/games-board/chessx/metadata.xml b/games-board/chessx/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-board/chessx/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>