summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-engines/exult
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-engines/exult')
-rw-r--r--games-engines/exult/exult-9999.ebuild60
-rw-r--r--games-engines/exult/metadata.xml5
2 files changed, 65 insertions, 0 deletions
diff --git a/games-engines/exult/exult-9999.ebuild b/games-engines/exult/exult-9999.ebuild
new file mode 100644
index 000000000000..7acaa7395819
--- /dev/null
+++ b/games-engines/exult/exult-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ESVN_REPO_URI="https://svn.code.sf.net/p/exult/code/exult/trunk/"
+inherit autotools multilib eutils subversion games
+
+DESCRIPTION="an Ultima 7 game engine that runs on modern operating systems"
+HOMEPAGE="http://exult.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="timidity zlib"
+
+DEPEND=">=media-libs/libpng-1.2.43-r2:0
+ games-misc/exult-sound
+ media-libs/libsdl[sound,video,X]
+ timidity? ( >=media-sound/timidity++-2 )
+ zlib? ( sys-libs/zlib )"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${P/_/}
+
+src_unpack() {
+ subversion_src_unpack
+}
+
+src_prepare() {
+ subversion_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --x-libraries="/usr/$(get_libdir)" \
+ --disable-tools \
+ --disable-opengl \
+ --enable-mods \
+ --with-desktopdir=/usr/share/applications \
+ --with-icondir=/usr/share/pixmaps \
+ $(use_enable timidity timidity-midi) \
+ $(use_enable zlib zip-support)
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog NEWS FAQ README README.1ST" \
+ default
+ # no need for this directory for just playing the game
+ #rm -rf "${D}${GAMES_DATADIR}/${PN}/estudio"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "You *must* have the original Ultima7 The Black Gate and/or"
+ elog "The Serpent Isle installed."
+ elog "See documentation in /usr/share/doc/${PF} for information."
+}
diff --git a/games-engines/exult/metadata.xml b/games-engines/exult/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-engines/exult/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>