summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-05-24 15:51:31 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2016-05-24 15:51:48 -0400
commitc795db0ecbe94b4a02084f67a30d323dd1bb9210 (patch)
tree3e46dacbe78763a96794cca85f4781d1454263d4 /games-engines/openmw
parentgames-strategy/openra: clean unused use flag from metadata.xml (diff)
downloadgentoo-c795db0ecbe94b4a02084f67a30d323dd1bb9210.tar.gz
gentoo-c795db0ecbe94b4a02084f67a30d323dd1bb9210.tar.bz2
gentoo-c795db0ecbe94b4a02084f67a30d323dd1bb9210.zip
games-engines/openmw: version bump (bug #567742)
Package-Manager: portage-2.2.28
Diffstat (limited to 'games-engines/openmw')
-rw-r--r--games-engines/openmw/Manifest1
-rw-r--r--games-engines/openmw/openmw-0.39.0.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/games-engines/openmw/Manifest b/games-engines/openmw/Manifest
index 3568e8aab926..7efa1b215f54 100644
--- a/games-engines/openmw/Manifest
+++ b/games-engines/openmw/Manifest
@@ -1 +1,2 @@
DIST openmw-0.36.1.tar.gz 4186134 SHA256 c83fddf3302dd8040330e2d41a9656bb66b1fc8224b24d685d8792b15f74af22 SHA512 9cbd9db876bacc736ab071a6074d92c44b1497780a2a6f4dbff5f109107173baae5490af92c1092985863897d63e063336fe1a8093269fd7b3ce48dee550425d WHIRLPOOL 305a87faea65413629b0e639280dba1462ade723b130e82bab823d86658066656fe250e81a26e1415b81ebed39a790e278f443fa2c92657422eb9ac9ba681faf
+DIST openmw-0.39.0.tar.gz 4764754 SHA256 b0d294b0814099bd93326f7b86dd84fb727d38dd536bf104272112e6d70ae720 SHA512 05b9ed89d04f55fad4358a9920af1d702a1957f54233e613737126278318e7c64cacfc557c6ba43d2282454a825b1c9e225e9429d11ba0f03c5c6dd93124d91a WHIRLPOOL bb3744e1fdf4e63c02c055237eb3a749ded32da097259f6f065d331681b214be932eeb4b654c91747fb5356dbb0e88f603e0f1a4113bb3f791f9e1b3d7e6b53f
diff --git a/games-engines/openmw/openmw-0.39.0.ebuild b/games-engines/openmw/openmw-0.39.0.ebuild
new file mode 100644
index 000000000000..dc2e5706ce1a
--- /dev/null
+++ b/games-engines/openmw/openmw-0.39.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils cmake-utils games
+
+DESCRIPTION="An open source reimplementation of TES III: Morrowind"
+HOMEPAGE="http://openmw.org/"
+SRC_URI="https://github.com/OpenMW/openmw/archive/${P}.tar.gz"
+
+LICENSE="GPL-3 MIT BitstreamVera OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc devtools"
+
+RDEPEND="
+ >=dev-games/openscenegraph-3.3.4[ffmpeg,jpeg,png,qt5,sdl,svg,truetype,zlib]
+ || ( media-libs/libtxc_dxtn x11-drivers/ati-drivers x11-drivers/nvidia-drivers )
+ app-arch/unshield
+ >=dev-games/mygui-3.2.2
+ >=dev-libs/boost-1.56.0-r1
+ dev-libs/tinyxml
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ media-libs/freetype:2
+ media-libs/libsdl2[joystick,opengl,X,video]
+ media-libs/openal
+ >=sci-physics/bullet-2.80
+ virtual/ffmpeg
+ virtual/opengl
+ devtools? ( dev-qt/qtxmlpatterns:5 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen media-gfx/graphviz )"
+
+S=${WORKDIR}/${PN}-${P}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBINDIR="${GAMES_BINDIR}"
+ $(cmake-utils_use_build devtools BSATOOL)
+ $(cmake-utils_use_build devtools ESMTOOL)
+ $(cmake-utils_use_build devtools OPENCS)
+ -DBUILD_UNITTESTS=OFF
+ -DDATADIR="${GAMES_DATADIR}"/${PN}
+ -DICONDIR="/usr/share/icons/hicolor/256x256/apps"
+ -DLIBDIR="$(games_get_libdir)"
+ -DMORROWIND_DATA_FILES="${GAMES_DATADIR}"/morrowind-data
+ -DOPENMW_RESOURCE_FILES="${GAMES_DATADIR}"/${PN}/resources
+ -DGLOBAL_CONFIG_PATH="${GAMES_SYSCONFDIR}"
+ -DUSE_SYSTEM_TINYXML=ON
+ -DDESIRED_QT_VERSION=5
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ if use doc ; then
+ emake -C "${CMAKE_BUILD_DIR}" doc
+ find "${CMAKE_BUILD_DIR}"/docs/Doxygen/html \
+ -name '*.md5' -type f -delete || die
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc README.md
+
+ # about 47k files, dodoc seems to have trouble
+ if use doc ; then
+ dodir "/usr/share/doc/${PF}"
+ mv "${CMAKE_BUILD_DIR}"/docs/Doxygen/html \
+ "${D}/usr/share/doc/${PF}/" || die
+ fi
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+
+ elog "You need the original Morrowind Data files. If you haven't"
+ elog "installed them yet, you can install them straight via the"
+ elog "installation wizard which is the officially"
+ elog "supported method (either by using the launcher or by calling"
+ elog "'openmw-wizard' directly)."
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}