summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-engines/residualvm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-engines/residualvm')
-rw-r--r--games-engines/residualvm/Manifest1
-rw-r--r--games-engines/residualvm/metadata.xml8
-rw-r--r--games-engines/residualvm/residualvm-0.2.1.ebuild89
3 files changed, 98 insertions, 0 deletions
diff --git a/games-engines/residualvm/Manifest b/games-engines/residualvm/Manifest
new file mode 100644
index 000000000000..b172037f1d44
--- /dev/null
+++ b/games-engines/residualvm/Manifest
@@ -0,0 +1 @@
+DIST residualvm-0.2.1-sources.tar.bz2 5533814 SHA256 cd2748a665f80b8c527c6dd35f8435e718d2e10440dca10e7765574c7402d924 SHA512 9eed93770ef1ad828934c32e937b861c93f1ebbb0d936f3f56668e654588f734dc88e29446f0a69f8f26475e96b8ce7ca85318758b99aabc9586756692c721da WHIRLPOOL fd055dc5f85ae653f38f6de6a4d80aad32aa77164ab997fb2cc64cd23284b1af7531d9a1076cdd903e6edc8bf48b6e455c42f0adb997ea7eeda660d958e3319b
diff --git a/games-engines/residualvm/metadata.xml b/games-engines/residualvm/metadata.xml
new file mode 100644
index 000000000000..6e55bbad6584
--- /dev/null
+++ b/games-engines/residualvm/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">residualvm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-engines/residualvm/residualvm-0.2.1.ebuild b/games-engines/residualvm/residualvm-0.2.1.ebuild
new file mode 100644
index 000000000000..373734a181cb
--- /dev/null
+++ b/games-engines/residualvm/residualvm-0.2.1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs gnome2-utils games
+
+DESCRIPTION="A cross-platform 3D game interpreter for play LucasArts' LUA-based 3D adventures"
+HOMEPAGE="http://www.residualvm.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-sources.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+# TODO: fix dynamic plugin support
+# games crash without media-libs/libsdl[alsa]
+RDEPEND="
+ media-libs/alsa-lib
+ media-libs/freetype:2
+ media-libs/libsdl[X,sound,alsa,joystick,opengl,video]
+ sys-libs/zlib
+ virtual/glu
+ virtual/opengl"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # not an autotools script
+ # most configure options currently do nothing, recheck on version bump !!!
+ # disable explicitly, otherwise we get unneeded linkage (some copy-paste build system)
+ ./configure \
+ --disable-debug \
+ --enable-all-engines \
+ --backend=sdl \
+ --enable-release-mode \
+ --disable-tremor \
+ --disable-sparkle \
+ --prefix="${GAMES_PREFIX}" \
+ --datadir="${GAMES_DATADIR}/${PN}" \
+ --libdir="$(games_get_libdir)" \
+ --docdir="/usr/share/doc/${PF}" \
+ --disable-libunity \
+ --disable-faad \
+ --disable-flac \
+ --disable-fluidsynth \
+ --disable-mad \
+ --disable-translation \
+ --disable-vorbis \
+ --enable-zlib \
+ || die "configure failed"
+}
+
+src_compile() {
+ emake \
+ VERBOSE_BUILD=1 \
+ AR="$(tc-getAR) cru" \
+ RANLIB=$(tc-getRANLIB)
+}
+
+src_install() {
+ dogamesbin residualvm
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins gui/themes/modern.zip dists/engine-data/residualvm-grim-patch.lab
+
+ doicon -s scalable icons/${PN}.svg
+ doicon -s 256 icons/${PN}.png
+ domenu dists/${PN}.desktop
+
+ doman dists/${PN}.6
+ dodoc AUTHORS README.md KNOWN_BUGS TODO
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}