summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikos Chantziaras <realnc@gmail.com>2018-03-14 06:50:38 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-03-20 22:20:13 +0100
commit7fbf362015ccde1a123931e8419854b17d8240de (patch)
tree73c3361b319be87ca301c612778e0a2b7001e4c9 /games-engines
parentdev-python/python-ldap: update HOMEPAGE, use HTTPS (diff)
downloadgentoo-7fbf362015ccde1a123931e8419854b17d8240de.tar.gz
gentoo-7fbf362015ccde1a123931e8419854b17d8240de.tar.bz2
gentoo-7fbf362015ccde1a123931e8419854b17d8240de.zip
games-engines/frobtads: version bump to 1.2.4.
Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://bugs.gentoo.org/650440 Closes: https://github.com/gentoo/gentoo/pull/7454
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/frobtads/Manifest1
-rw-r--r--games-engines/frobtads/frobtads-1.2.4.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/games-engines/frobtads/Manifest b/games-engines/frobtads/Manifest
index cc66446b02fc..57cba13d3730 100644
--- a/games-engines/frobtads/Manifest
+++ b/games-engines/frobtads/Manifest
@@ -1 +1,2 @@
DIST frobtads-1.2.3.tar.gz 5227704 BLAKE2B fd481201da6dbddf3b0f5adf7c600282c9500bd65cebebf13e23b139ca1e9793091c6df50bebebed179c6f775d188c8ccbe8450d0058863c55dd322e8a92ce32 SHA512 4efb888860edda24bb5a5812967d0b863614558e9839cf0cfabc649ab0175719bf663de5e725034ba160c015d269dbe2df046cf47ad1019e668bf5b1fb564d7d
+DIST frobtads-1.2.4.tar.bz2 3801366 BLAKE2B 871a4cfd432f1a72915de0652def2f2a9a3cf1bfa20b070c2e59ced673c736584a36b3d17e7d5812ad7cd883c3e038e49f962635a5794d6c914d99651bfd0a55 SHA512 f49f58114cbd78f23fcc3835025af7874da968af825abd449e9ab83c4a90e8d70f8cfafa83780f0631ae9bd2793cce2d5dd947c13ee38ba0d06829d2803abf12
diff --git a/games-engines/frobtads/frobtads-1.2.4.ebuild b/games-engines/frobtads/frobtads-1.2.4.ebuild
new file mode 100644
index 000000000000..7f2b43c14462
--- /dev/null
+++ b/games-engines/frobtads/frobtads-1.2.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Curses-based interpreter and dev tools for TADS 2 and TADS 3 text adventures"
+HOMEPAGE="http://www.tads.org/frobtads.htm"
+SRC_URI="https://github.com/realnc/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="TADS2 TADS3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug tads2compiler tads3compiler"
+
+RESTRICT="!tads3compiler? ( test )"
+
+RDEPEND="net-misc/curl
+ sys-libs/ncurses:0"
+DEPEND=${RDEPEND}
+
+DOCS=( doc/{AUTHORS,BUGS,ChangeLog.old,NEWS,README,SRC_GUIDELINES,THANKS} )
+
+src_configure() {
+ econf \
+ $(use_enable debug error-checking) \
+ $(use_enable debug t3debug) \
+ $(use_enable tads2compiler t2-compiler) \
+ $(use_enable tads3compiler t3-compiler)
+}
+
+src_test() {
+ emake -j1 sample
+ ./frob -i plain -p samples/sample.t3 <<- END_FROB_TEST
+ save
+ testsave.sav
+ restore
+ testsave.sav
+ END_FROB_TEST
+ [[ $? -eq 0 ]] || die "Failed to run test game"
+}