summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-mud/gmudix
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-mud/gmudix')
-rw-r--r--games-mud/gmudix/Manifest1
-rw-r--r--games-mud/gmudix/files/gmudix-1.0-as-needed.patch28
-rw-r--r--games-mud/gmudix/gmudix-1.0.ebuild32
-rw-r--r--games-mud/gmudix/metadata.xml5
4 files changed, 66 insertions, 0 deletions
diff --git a/games-mud/gmudix/Manifest b/games-mud/gmudix/Manifest
new file mode 100644
index 000000000000..129e687b9a41
--- /dev/null
+++ b/games-mud/gmudix/Manifest
@@ -0,0 +1 @@
+DIST gmudix-1.0.tar.gz 137548 SHA256 92588f498f5188ade961b7fd53951300236af105a72d0ffbd586d03a13008b03 SHA512 c22a725af6914d5177a737c1abf1ee38c133854fab8723dc01a89739b58214937008c3931ccc5928e88ee1ecbda385304ff862606eacec377addd6ee8de02b38 WHIRLPOOL 1467d80d629232e6eabbc75e111e652d458b559d6d7edd749a5d9479c2ad9502aba700ed8e072254b9fca991a2868b3ef5ba0a19b3f0814cd6f2326f85dd977d
diff --git a/games-mud/gmudix/files/gmudix-1.0-as-needed.patch b/games-mud/gmudix/files/gmudix-1.0-as-needed.patch
new file mode 100644
index 000000000000..838376ef256f
--- /dev/null
+++ b/games-mud/gmudix/files/gmudix-1.0-as-needed.patch
@@ -0,0 +1,28 @@
+--- configure.in
++++ configure.in
+@@ -8,7 +8,8 @@
+ AC_PROG_MAKE_SET
+
+ dnl Checks for libraries.
+-PKG_CHECK_MODULES(BASE_DEPENDENCIES, gtk+-2.0 >= 2.0.0)
++PKG_CHECK_MODULES(GTK, gtk+-2.0)
++PKG_CHECK_MODULES(GTHREAD, gthread-2.0)
+
+ dnl Checks for header files.
+ AC_HEADER_STDC
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -1,10 +1,5 @@
+ bin_PROGRAMS = gmudix
+ gmudix_SOURCES = alias.c commands.c file.c gui_alias.c gui_capture.c gui_character.c gui_color.c gui_font.c gui_general.c gui_macro.c gui_main.c gui_path.c gui_preferences.c gui_tab.c gui_timer.c gui_trigger.c gui_user.c gui_variable.c history.c log.c macro.c mccp.c mudix.c net.c path.c process.c string.c tabs.c telnet.c timer.c trigger.c user.c variable.c
+-INCLUDES = -Wall -I.. -I../include `pkg-config --cflags gtk+-2.0`
+-gmudix_LDFLAGS = -lz `pkg-config --libs gtk+-2.0` `pkg-config --libs gthread-2.0`
+-
+-if DEBUG_SYMBOLS
+-CFLAGS := $(CFLAGS) -O2 -g
+-else
+-CFLAGS := $(CFLAGS) -O2
+-endif
++AM_CFLAGS = -Wall
++INCLUDES = -I.. -I../include $(GTK_CFLAGS) $(GTHREAD_CFLAGS)
++LDADD = -lz $(GTK_LIBS) $(GTHREAD_LIBS)
diff --git a/games-mud/gmudix/gmudix-1.0.ebuild b/games-mud/gmudix/gmudix-1.0.ebuild
new file mode 100644
index 000000000000..1490308617cc
--- /dev/null
+++ b/games-mud/gmudix/gmudix-1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils games
+
+DESCRIPTION="GTK+ MUD client with ANSI color, macros, timers, triggers, variables, and an easy scripting language"
+HOMEPAGE="http://dw.nl.eu.org/mudix.html"
+SRC_URI="http://dw.nl.eu.org/gmudix/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ mv configure.in configure.ac || die
+ rm -f missing || die
+ eautoreconf
+}
+
+src_install() {
+ dogamesbin src/${PN}
+ dodoc AUTHORS ChangeLog README TODO doc/*txt
+ prepgamesdirs
+}
diff --git a/games-mud/gmudix/metadata.xml b/games-mud/gmudix/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-mud/gmudix/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>