summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <stefan.strogin@gmail.com>2019-02-13 02:43:02 +0200
committerJames Le Cuirot <chewi@gentoo.org>2019-03-09 22:16:12 +0000
commit528be1ea6b33d965547036ff07e5f03cc8900247 (patch)
tree3d438bcc1b3ec32d42ed8717efe27ac367ba4c50 /games-roguelike
parentgames-roguelike/angband: migrate from versionator to eapi7-ver (diff)
downloadgentoo-528be1ea6b33d965547036ff07e5f03cc8900247.tar.gz
gentoo-528be1ea6b33d965547036ff07e5f03cc8900247.tar.bz2
gentoo-528be1ea6b33d965547036ff07e5f03cc8900247.zip
games-roguelike/angband: minor improvements
- Empty line after EAPI=6. - Use https. - Remove unused eutils eclass. - Sort RDEPEND list. - Remove a misplaced bracket so that media-libs/sdl-mixer[mp3] is required only with USE=sound enabled. - Remove redundant gnome2_icon_savelist call - Remove obsolete message in pkg_postinst - Some stylistic changes. Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com> Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/angband/angband-4.1.3.ebuild50
1 files changed, 18 insertions, 32 deletions
diff --git a/games-roguelike/angband/angband-4.1.3.ebuild b/games-roguelike/angband/angband-4.1.3.ebuild
index 00fd80617c2d..e6a478bf9426 100644
--- a/games-roguelike/angband/angband-4.1.3.ebuild
+++ b/games-roguelike/angband/angband-4.1.3.ebuild
@@ -2,27 +2,32 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools eapi7-ver eutils gnome2-utils
+
+inherit autotools eapi7-ver gnome2-utils
MAJOR_PV=$(ver_cut 1-2)
DESCRIPTION="A roguelike dungeon exploration game based on the books of J.R.R. Tolkien"
-HOMEPAGE="http://rephial.org/"
-SRC_URI="http://rephial.org/downloads/${MAJOR_PV}/${P}.tar.gz"
+HOMEPAGE="https://rephial.org/"
+SRC_URI="https://rephial.org/downloads/${MAJOR_PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="ncurses sdl +sound X"
-RDEPEND="X? ( x11-libs/libX11 )
- !ncurses? ( !X? ( !sdl? ( sys-libs/ncurses:0=[unicode] ) ) )
+RDEPEND="!ncurses? ( !X? ( !sdl? ( sys-libs/ncurses:0=[unicode] ) ) )
ncurses? ( sys-libs/ncurses:0=[unicode] )
- sdl? ( media-libs/libsdl[video,X]
+ sdl? (
+ media-libs/libsdl[video,X]
media-libs/sdl-image
media-libs/sdl-ttf
- sound? ( media-libs/libsdl[sound] )
- media-libs/sdl-mixer[mp3] )"
+ sound? (
+ media-libs/libsdl[sound]
+ media-libs/sdl-mixer[mp3]
+ )
+ )
+ X? ( x11-libs/libX11 )"
DEPEND="${RDEPEND}
dev-python/docutils
virtual/pkgconfig"
@@ -70,43 +75,24 @@ src_configure() {
}
src_install() {
- DOCS="changes.txt faq.txt readme.txt thanks.txt" \
- default
+ default
- dodoc doc/manual.html
+ dodoc changes.txt faq.txt readme.txt thanks.txt doc/manual.html
doenvd "${T}"/99${PN}
if use X || use sdl ; then
- if use X; then
- make_desktop_entry "angband -mx11" "Angband (X11)" "${PN}"
- fi
-
- if use sdl; then
- make_desktop_entry "angband -msdl" "Angband (SDL)" "${PN}"
- fi
+ use X && make_desktop_entry "angband -mx11" "Angband (X11)" "${PN}"
+ use sdl && make_desktop_entry "angband -msdl" "Angband (SDL)" "${PN}"
local s
- for s in 16 32 128 256 512
- do
+ for s in 16 32 128 256 512; do
newicon -s ${s} lib/icons/att-${s}.png "${PN}.png"
done
newicon -s scalable lib/icons/att.svg "${PN}.svg"
fi
}
-pkg_preinst() {
- if use X || use sdl ; then
- gnome2_icon_savelist
- fi
-}
-
pkg_postinst() {
- echo
- elog "Angband now uses private savefiles instead of system-wide ones."
- elog "This version of Angband is not compatible with the save files"
- elog "of previous versions."
- echo
-
if use X || use sdl ; then
gnome2_icon_cache_update
fi