summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Levitsky <kitsunenokenja@protonmail.ch>2018-10-27 08:31:40 -0400
committerMichał Górny <mgorny@gentoo.org>2018-10-30 11:44:06 +0100
commit66d0410a06486c6ede1b7e749d486a358b3e9d81 (patch)
tree6322fedda4e85177871716d0d74a032be11890fd /games-roguelike
parentsys-cluster/hpx: version bump (diff)
downloadgentoo-66d0410a06486c6ede1b7e749d486a358b3e9d81.tar.gz
gentoo-66d0410a06486c6ede1b7e749d486a358b3e9d81.tar.bz2
gentoo-66d0410a06486c6ede1b7e749d486a358b3e9d81.zip
games-roguelike/FTL-gog: Bump version to 1.6.8.24110
Signed-off-by: Rob Levitsky <kitsunenokenja@protonmail.ch> Package-Manager: Portage-2.3.49, Repoman-2.3.11 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/FTL-gog/FTL-gog-1.6.8.24110.ebuild63
-rw-r--r--games-roguelike/FTL-gog/Manifest1
2 files changed, 64 insertions, 0 deletions
diff --git a/games-roguelike/FTL-gog/FTL-gog-1.6.8.24110.ebuild b/games-roguelike/FTL-gog/FTL-gog-1.6.8.24110.ebuild
new file mode 100644
index 000000000000..a70fe76bef53
--- /dev/null
+++ b/games-roguelike/FTL-gog/FTL-gog-1.6.8.24110.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop unpacker
+
+DESCRIPTION="Top-down roguelike space ship simulator"
+HOMEPAGE="https://www.gog.com/game/faster_than_light"
+SRC_URI="ftl_advanced_edition_${PV//./_}.sh"
+RESTRICT="bindist fetch mirror strip test"
+
+LICENSE="GOG-EULA"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="media-libs/freetype
+ media-libs/libsdl[X,sound,opengl,video]
+ media-libs/libpng
+ sys-libs/zlib
+ virtual/opengl"
+
+S="${WORKDIR}/data/noarch"
+
+pkg_nofetch() {
+ elog "Please buy and download ${SRC_URI} from"
+ elog "https://www.gog.com/game/faster_than_light"
+}
+
+src_unpack() {
+ unpack_zip "${DISTDIR}/${A}"
+}
+
+src_prepare() {
+ default
+ rm -r support/{xdg*,*.{sh,txt}} || die
+ if ! use x86; then
+ rm game/data/FTL.x86 || die
+ fi
+ if ! use amd64; then
+ rm game/data/FTL.amd64 || die
+ fi
+
+ sed -i start.sh -e '/chmod/d'
+}
+
+src_install() {
+ insinto /opt/gog/FTL
+ doins -r .
+ fperms +x /opt/gog/FTL/{start.sh,game/FTL,game/data/FTL}
+
+ if use x86; then
+ fperms +x /opt/gog/FTL/game/data/FTL.x86
+ fi
+ if use amd64; then
+ fperms +x /opt/gog/FTL/game/data/FTL.amd64
+ fi
+
+ make_desktop_entry "/opt/gog/FTL/start.sh" "FTL: Advanced Edition" FTL
+ newicon support/icon.png FTL.png
+}
diff --git a/games-roguelike/FTL-gog/Manifest b/games-roguelike/FTL-gog/Manifest
index d3e140d5640d..22b9a04b9b2c 100644
--- a/games-roguelike/FTL-gog/Manifest
+++ b/games-roguelike/FTL-gog/Manifest
@@ -1 +1,2 @@
+DIST ftl_advanced_edition_1_6_8_24110.sh 201034290 BLAKE2B 6ed07bcbcacaf81704682be438ae8bfa4ccfe906e2845ad25550b081d33964f8c3d6f40326a56168b072e99e0c30190579bcd756f8a3c055a5b54907a0913014 SHA512 ad66211ad077738797d0a8f33bc43c01dbcd6bdff3e4d9a8316e0ebca06a94b76380911e54c4b16dfc2f836cdbb6a025383714f0de4b9f9c19376660a695c678
DIST ftl_advanced_edition_en_1_6_7_18662.sh 190506416 BLAKE2B 0a628e4de3a5539add2f421377c32ead5397ad1709e30124aa8c9d0874b98eb37cda97873b21dbb78fe635769c1a3c3254988ae22494805409d28f5e33417e44 SHA512 3e9c08d32964e21b49ad3e1b6a17c2349d516fdbea4118518e022134affc43dd27d2e60eea94784096aea4725f2656b43f6b6be9fe02eaed743c167ef842d66b