summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-06 03:12:36 +0100
committerSam James <sam@gentoo.org>2021-04-06 19:18:15 +0100
commit6052f2dea19da59f8edfdcb8f3ea9cd0ae0f40e6 (patch)
treec56a8175c58380a6a220db110e9212a189f08286 /games-rpg
parentgames-arcade/cavezofphear: port to EAPI 7, games.eclass--, respect PKG_CONFIG (diff)
downloadgentoo-6052f2dea19da59f8edfdcb8f3ea9cd0ae0f40e6.tar.gz
gentoo-6052f2dea19da59f8edfdcb8f3ea9cd0ae0f40e6.tar.bz2
gentoo-6052f2dea19da59f8edfdcb8f3ea9cd0ae0f40e6.zip
games-rpg/to-the-moon: port to EAPI 7, games.eclass--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/to-the-moon/to-the-moon-0-r1.ebuild (renamed from games-rpg/to-the-moon/to-the-moon-0.ebuild)34
1 files changed, 18 insertions, 16 deletions
diff --git a/games-rpg/to-the-moon/to-the-moon-0.ebuild b/games-rpg/to-the-moon/to-the-moon-0-r1.ebuild
index b55f9b6f24f4..14c390ecc21f 100644
--- a/games-rpg/to-the-moon/to-the-moon-0.ebuild
+++ b/games-rpg/to-the-moon/to-the-moon-0-r1.ebuild
@@ -1,31 +1,34 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# TODO: unbundling sdl-sound breaks the game
-
-EAPI=5
+EAPI=7
-inherit eutils unpacker gnome2-utils games
+inherit desktop gnome2-utils unpacker wrapper
MY_PN=ToTheMoon
DESCRIPTION="Two doctors traversing the memories of a dying man to fulfill his last wish"
HOMEPAGE="http://freebirdgames.com/games/to-the-moon"
SRC_URI="${MY_PN}_linux_1389114090.sh"
+S="${WORKDIR}"/data
LICENSE="all-rights-reserved bundled-libs? ( LGPL-2 LGPL-2.1 ZLIB )"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="bundled-libs"
+
RESTRICT="fetch bindist splitdebug"
-QA_PREBUILT="${GAMES_PREFIX_OPT}/${PN}/${MY_PN}.bin*"
+QA_PREBUILT="opt/${PN}/${MY_PN}.bin*"
if [[ ${ARCH} == "amd64" ]] ; then
QA_PREBUILT="${QA_PREBUILT} ${GAMES_PREFIX_OPT}/${PN}/lib64/*"
else
QA_PREBUILT="${QA_PREBUILT} ${GAMES_PREFIX_OPT}/${PN}/lib/*"
fi
+# TODO: unbundling sdl-sound breaks the game
RDEPEND="
+ sys-libs/zlib
+ virtual/opengl
!bundled-libs? (
dev-libs/libsigc++:2
>=media-libs/libsdl2-2.0.1[X,joystick,opengl,sound,threads,video]
@@ -33,10 +36,11 @@ RDEPEND="
media-libs/sdl2-image[png]
media-libs/sdl2-ttf
)
- sys-libs/zlib
- virtual/opengl"
-
-S=${WORKDIR}/data
+"
+DEPEND="
+ sys-apps/coreutils
+ sys-apps/grep
+"
pkg_nofetch() {
einfo
@@ -50,14 +54,16 @@ src_unpack() {
# mojo stuff inside makeself archive, unpack_makeself fails
local lastline=$(( $(grep -a -h -n -m 1 -F -e "Extra newline, because in very rare cases (OpenSolaris) stub is directly added after script" "${DISTDIR}/${A}" | cut -d':' -f1) + 1 ))
[[ ${lastline} ]] || die "no last line"
+
local offset=$(head -n ${lastline} "${DISTDIR}/${A}" | wc -c)
[[ ${offset} ]] || die "no offset"
+
dd ibs=${offset} skip=1 if="${DISTDIR}/${A}" of="${T}"/moon.zip || die
unpack_zip "${T}"/moon.zip
}
src_install() {
- local dir=${GAMES_PREFIX_OPT}/${PN}
+ local dir=opt/${PN}
local libsuffix=$(usex amd64 "64" "")
local arch=$(usex amd64 "x86_64" "x86")
@@ -74,20 +80,16 @@ src_install() {
doexe ${arch}/lib${libsuffix}/libSDL_sound-1.0.so.1
fi
- games_make_wrapper ${PN} "./${MY_PN}.bin.${arch}" "${dir}" "${dir}/lib${libsuffix}"
+ make_wrapper ${PN} "./${MY_PN}.bin.${arch}" "${dir}" "${dir}/lib${libsuffix}"
make_desktop_entry ${PN} "To the Moon"
newicon -s 32 noarch/${MY_PN}.png ${PN}.png
-
- prepgamesdirs
}
pkg_preinst() {
- games_pkg_preinst
gnome2_icon_savelist
}
pkg_postinst() {
- games_pkg_postinst
gnome2_icon_cache_update
}