summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-08-05 12:36:12 -0500
committerAustin English <wizardedit@gentoo.org>2016-08-05 12:38:46 -0500
commit0283d05ca2837753f4cc01fa026ed73c97ad8600 (patch)
treef6aee04658ab4fe66fa7c9703a731c174f6ef427 /games-server/monopd
parentgames-server/mednafen-server: remove deprecated games eclass (diff)
downloadgentoo-0283d05ca2837753f4cc01fa026ed73c97ad8600.tar.gz
gentoo-0283d05ca2837753f4cc01fa026ed73c97ad8600.tar.bz2
gentoo-0283d05ca2837753f4cc01fa026ed73c97ad8600.zip
games-server/monopd: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-server/monopd')
-rw-r--r--games-server/monopd/monopd-0.10.2-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/games-server/monopd/monopd-0.10.2-r1.ebuild b/games-server/monopd/monopd-0.10.2-r1.ebuild
new file mode 100644
index 000000000000..d736ef719f40
--- /dev/null
+++ b/games-server/monopd/monopd-0.10.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils systemd
+
+DESCRIPTION="server for atlantik games"
+HOMEPAGE="http://gtkatlantic.gradator.net/"
+SRC_URI="http://download.tuxfamily.org/gtkatlantic/monopd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="systemd"
+
+RDEPEND="systemd? ( sys-apps/systemd )"
+DEPEND="${RDEPEND}
+ >=dev-cpp/muParser-2
+ dev-libs/utfcpp"
+
+src_prepare() {
+ default
+
+ sed "s:GENTOO_DIR:\"/usr/bin\":" \
+ "${FILESDIR}"/monopd.in > "${T}"/monopd || die
+ sed -i \
+ -e "s:/usr/sbin:/usr/bin:" \
+ doc/systemd/monopd.service || die
+ sed -i \
+ -e '/C_SUBST(CXXFLAGS/s/CFLAGS/CXXFLAGS/' \
+ configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with systemd systemd-daemon)
+}
+
+src_install() {
+ default
+ doinitd "${T}"/monopd
+ systemd_dounit doc/systemd/monopd.s*
+}