summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-08-26 13:30:11 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-08-26 13:30:11 +0200
commit99768f875184b347176812922de24e337866a1ce (patch)
tree7ed0a7f7d9c4b13046f624895f6667c4fcc37a7b /games-util/lutris
parentgames-util/lutris: add 0.5.11 (diff)
downloadgentoo-99768f875184b347176812922de24e337866a1ce.tar.gz
gentoo-99768f875184b347176812922de24e337866a1ce.tar.bz2
gentoo-99768f875184b347176812922de24e337866a1ce.zip
games-util/lutris: drop 0.5.11_beta1
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'games-util/lutris')
-rw-r--r--games-util/lutris/Manifest1
-rw-r--r--games-util/lutris/lutris-0.5.11_beta1.ebuild82
2 files changed, 0 insertions, 83 deletions
diff --git a/games-util/lutris/Manifest b/games-util/lutris/Manifest
index 8da9fa2bd6f7..278e4b2fbff7 100644
--- a/games-util/lutris/Manifest
+++ b/games-util/lutris/Manifest
@@ -1,3 +1,2 @@
-DIST lutris-0.5.11_beta1.tar.gz 1118646 BLAKE2B 7d414c2084d1c2c714d102d98a7f2f1d6ef004b2175b8c5c023a8c455e5753910827ee33107250162ffc0b7e352a9ce2c2c37b1efd01caa14fb324808925878d SHA512 764e8a2c2c59d094708bff3c81acdaba09aa0d9d37c304acf7ddf0fa900db0e064b19dd38933ee62b7e7f6b792518968833a11078c24421db5b2c9b77e093fb6
DIST lutris_0.5.10.1.tar.xz 1230464 BLAKE2B 5ba913f5e37956344b59c47c1315cf277ce57b1b771279c8aa4243971ea9f0c5277ad19b18655731048e989f752d957216d055ac6c26bb8731e52b4345d30847 SHA512 f6443fa86d0b38e1b5ba51054e50776eea63d9adda5738a7e69f2fe6b196f99491894d5068d6cddfd35d1baafa4188bd1935598b84266e9e23bd1b58c16dde20
DIST lutris_0.5.11.tar.xz 1337572 BLAKE2B 9baeaa078483812c25754691cde80324155a69fde7edc1aec043df806ceb0cbe05e04c71c73d9ff355d2aaa2f21d9e53871a1752b02022ae8527b69ed31cf47c SHA512 16b06f6a3377bfa8db5c3b1e1b3872cbfbd5e7ff27975b51083142dce9931c90a9827f8da7b2d9ba7b21e65bc4ca1759f6a720c142a01f99532274e152cfde0a
diff --git a/games-util/lutris/lutris-0.5.11_beta1.ebuild b/games-util/lutris/lutris-0.5.11_beta1.ebuild
deleted file mode 100644
index 8808cea2f845..000000000000
--- a/games-util/lutris/lutris-0.5.11_beta1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-PYTHON_REQ_USE="sqlite,threads(+)"
-DISTUTILS_SINGLE_IMPL="1"
-
-inherit distutils-r1 optfeature virtualx xdg
-
-DESCRIPTION="An open source gaming platform for GNU/Linux"
-HOMEPAGE="https://lutris.net/"
-
-if [[ ${PV} == *9999* ]] ; then
- EGIT_REPO_URI="https://github.com/lutris/lutris.git"
- inherit git-r3
-else
- if [[ ${PV} == *_beta* ]] ; then
- SRC_URI="https://github.com/lutris/lutris/archive/refs/tags/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}"/${P/_/-}
- else
- SRC_URI="https://lutris.net/releases/${P/-/_}.tar.xz"
- S="${WORKDIR}/${PN}"
- KEYWORDS="~amd64 ~x86"
- fi
-fi
-
-LICENSE="GPL-3+ CC0-1.0"
-SLOT="0"
-
-RDEPEND="
- app-arch/cabextract
- app-arch/p7zip
- app-arch/unzip
- $(python_gen_cond_dep '
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/python-evdev[${PYTHON_USEDEP}]
- dev-python/python-magic[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- ')
- gnome-base/gnome-desktop:3[introspection]
- media-sound/fluid-soundfont
- net-libs/libsoup
- net-libs/webkit-gtk:4[introspection]
- x11-apps/mesa-progs
- x11-apps/xgamma
- x11-apps/xrandr
- x11-libs/gtk+:3[introspection]
- x11-libs/gdk-pixbuf[jpeg]
- x11-libs/libnotify[introspection]
-"
-
-distutils_enable_tests pytest
-
-DOCS=( AUTHORS README.rst docs/installers.rst docs/steam.rst )
-
-python_test() {
- virtx epytest
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- python_fix_shebang "${ED}/usr/share/lutris/bin/lutris-wrapper" #740048
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- optfeature "running windows games through wine+DXVK/proton or other Vulkan games (plus ICD for your hardware)" media-libs/vulkan-loader
-
- # Quote README.rst
- elog ""
- elog "Lutris installations are fully automated through scripts, which can"
- elog "be written in either JSON or YAML. The scripting syntax is described"
- elog "in ${EROOT}/usr/share/doc/${PF}/installers.rst.bz2, and is also"
- elog "available online at lutris.net."
-}