summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-10 03:22:37 +0100
committerSam James <sam@gentoo.org>2021-08-10 03:22:37 +0100
commitc29ad1f88ddf276ab3fb5740ae32a5d0fe576b87 (patch)
tree34e2785893ad5e8abe9092c73350062a4318ef5b /games-util/lutris
parentgames-util/lutris: drop 0.5.8.1 (diff)
downloadgentoo-c29ad1f88ddf276ab3fb5740ae32a5d0fe576b87.tar.gz
gentoo-c29ad1f88ddf276ab3fb5740ae32a5d0fe576b87.tar.bz2
gentoo-c29ad1f88ddf276ab3fb5740ae32a5d0fe576b87.zip
games-util/lutris: add 0.5.9_beta1 (unkeyworded)
Closes: https://bugs.gentoo.org/770880 Closes: https://bugs.gentoo.org/803236 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-util/lutris')
-rw-r--r--games-util/lutris/Manifest1
-rw-r--r--games-util/lutris/lutris-0.5.9_beta1.ebuild87
-rw-r--r--games-util/lutris/lutris-9999.ebuild42
3 files changed, 114 insertions, 16 deletions
diff --git a/games-util/lutris/Manifest b/games-util/lutris/Manifest
index 490e7ac933bb..788ed8e296fb 100644
--- a/games-util/lutris/Manifest
+++ b/games-util/lutris/Manifest
@@ -1,2 +1,3 @@
+DIST lutris-0.5.9_beta1.tar.gz 836915 BLAKE2B 53133b202e45a2e68e5aca273cd591055d469a2ada39d2b75db92d45da45a53cf3425b1d36fea1a7f241b9336895ada8b8e4577374cd0b1fd996cbd3f5108b1b SHA512 48b433fcf03795874e6c7f0b4d310f7a779c831ea67e754a0c9bb0b919f9f050311b002d63fa34150be753c4de452c306db16cb43c00fa91b08775c68169b7e6
DIST lutris_0.5.8.3.tar.xz 942716 BLAKE2B f831c6ad6f67c3948f07e89f9caacd0d8aa3878b912fe987afea85eea549f41347044967255fa80e4e0c4544d148d9782dfe3c5bf08a123436e8a5ef7034901f SHA512 8f653d38a9a551298fa344cde67d53bf50cfd2a0a0667e344d04f6e17dda4ef358037755975d1a7f74ecd39824d58f9586e8a82b70dccc26619f22fee94d1144
DIST lutris_0.5.8.4.tar.xz 957004 BLAKE2B f3acce5d9ea7368063a3135c1f503e0644c1cbc7676e966c262c8e04c5e0d23b4882793fe2df1beab265ab4128e8a90b5bb69401f8e567b0cceeea3008ff4fa7 SHA512 f79a9fd06788bc28e59ad6d2c403b83f8bdeaee0116ae7fbf765e80e4e08bf760a462c71f75a2ff46739e5757cb8609f5110a51d83266d3aba2f0c91524b6df9
diff --git a/games-util/lutris/lutris-0.5.9_beta1.ebuild b/games-util/lutris/lutris-0.5.9_beta1.ebuild
new file mode 100644
index 000000000000..4ca63a7a2a1f
--- /dev/null
+++ b/games-util/lutris/lutris-0.5.9_beta1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_REQ_USE="sqlite,threads(+)"
+DISTUTILS_SINGLE_IMPL="1"
+
+inherit distutils-r1 virtualx xdg
+
+DESCRIPTION="An open source gaming platform for GNU/Linux"
+HOMEPAGE="https://lutris.net/"
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/lutris/lutris.git"
+ inherit git-r3
+else
+ if [[ ${PV} == *_beta* ]] ; then
+ SRC_URI="https://github.com/lutris/lutris/archive/refs/tags/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${P/_/-}
+ else
+ SRC_URI="https://lutris.net/releases/${P/-/_}.tar.xz"
+ S="${WORKDIR}/${PN}"
+
+ KEYWORDS="~amd64 ~x86"
+ fi
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ app-arch/cabextract
+ app-arch/p7zip
+ app-arch/unzip
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-evdev[${PYTHON_USEDEP}]
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ')
+ gnome-base/gnome-desktop:3[introspection]
+ media-sound/fluid-soundfont
+ net-libs/libsoup
+ net-libs/webkit-gtk:4[introspection]
+ x11-apps/mesa-progs
+ x11-apps/xgamma
+ x11-apps/xrandr
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+"
+
+distutils_enable_tests nose
+
+src_prepare() {
+ default
+
+ # Avoid test failure:
+ # "ERROR: Failure: OSError (data_path can't be found at : /usr/share/lutris)"
+ sed -i -e "s:sys.path\[0\]:\"${S}/share\":" lutris/util/datapath.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ virtx nosetests -v
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS README.rst docs/installers.rst )
+ distutils-r1_python_install_all
+ python_fix_shebang "${ED}"/usr/share/lutris/bin/lutris-wrapper #740048
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ # Quote README.rst
+ elog "Lutris installations are fully automated through scripts, which can"
+ elog "be written in either JSON or YAML. The scripting syntax is described"
+ elog "in ${EROOT}/usr/share/doc/${PF}/installers.rst.bz2, and is also"
+ elog "available online at lutris.net."
+}
diff --git a/games-util/lutris/lutris-9999.ebuild b/games-util/lutris/lutris-9999.ebuild
index b29f07d71d87..4ca63a7a2a1f 100644
--- a/games-util/lutris/lutris-9999.ebuild
+++ b/games-util/lutris/lutris-9999.ebuild
@@ -16,22 +16,20 @@ if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://github.com/lutris/lutris.git"
inherit git-r3
else
- SRC_URI="https://lutris.net/releases/${P/-/_}.tar.xz"
- KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/${PN}"
+ if [[ ${PV} == *_beta* ]] ; then
+ SRC_URI="https://github.com/lutris/lutris/archive/refs/tags/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${P/_/-}
+ else
+ SRC_URI="https://lutris.net/releases/${P/-/_}.tar.xz"
+ S="${WORKDIR}/${PN}"
+
+ KEYWORDS="~amd64 ~x86"
+ fi
fi
LICENSE="GPL-3"
SLOT="0"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- test? (
- $(python_gen_cond_dep '
- dev-python/nose[${PYTHON_USEDEP}]
- ')
- )
-"
+
RDEPEND="
app-arch/cabextract
app-arch/p7zip
@@ -56,16 +54,28 @@ RDEPEND="
x11-libs/libnotify[introspection]
"
-python_install_all() {
- local DOCS=( AUTHORS README.rst docs/installers.rst )
- distutils-r1_python_install_all
- python_fix_shebang "${ED}"/usr/share/lutris/bin/lutris-wrapper #740048
+distutils_enable_tests nose
+
+src_prepare() {
+ default
+
+ # Avoid test failure:
+ # "ERROR: Failure: OSError (data_path can't be found at : /usr/share/lutris)"
+ sed -i -e "s:sys.path\[0\]:\"${S}/share\":" lutris/util/datapath.py || die
+
+ distutils-r1_src_prepare
}
python_test() {
virtx nosetests -v
}
+python_install_all() {
+ local DOCS=( AUTHORS README.rst docs/installers.rst )
+ distutils-r1_python_install_all
+ python_fix_shebang "${ED}"/usr/share/lutris/bin/lutris-wrapper #740048
+}
+
pkg_postinst() {
xdg_pkg_postinst