summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOursDesCavernes <totocoq@yahoo.fr>2018-09-06 23:55:41 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-09-10 15:23:18 +0200
commit76668420dc253b0acc4230c3937629b5979b2f71 (patch)
tree98e4a4d85e987d3b47f62b623ff917a21d0dfc5f /games-util
parentnet-fs/samba: Removed old. (diff)
downloadgentoo-76668420dc253b0acc4230c3937629b5979b2f71.tar.gz
gentoo-76668420dc253b0acc4230c3937629b5979b2f71.tar.bz2
gentoo-76668420dc253b0acc4230c3937629b5979b2f71.zip
games-util/springlobby: version bump to 0.266.
Closes: https://bugs.gentoo.org/665302 Package-Manager: Portage-2.3.40, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9788
Diffstat (limited to 'games-util')
-rw-r--r--games-util/springlobby/Manifest1
-rw-r--r--games-util/springlobby/springlobby-0.266.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/games-util/springlobby/Manifest b/games-util/springlobby/Manifest
index 40c8d80469e1..17f74119fb76 100644
--- a/games-util/springlobby/Manifest
+++ b/games-util/springlobby/Manifest
@@ -1 +1,2 @@
DIST springlobby-0.264.tar.bz2 2626180 BLAKE2B 01ff51703c3c10c1aaeb342d2644012a6037b1271ba7e36ab7663cde7646d1c9c6bd823fe65c91a8a9e754bbcf1000ce486eeab2d1641c64fad08773c491f9a6 SHA512 f8024a98be7d6ea755c4380494415813084aadb6dcf72ed0aaeba0ddf9fbaf992ccd5455713c807c0d6feb7db606068be62d4bb2cfcb4697f0406a2ec4f404eb
+DIST springlobby-0.266.tar.bz2 2642384 BLAKE2B 93444df4e139a657dc5d87b0ea9e796bd025259663693de9dcb04760ee611674546170813d71406e94aa456834cc96c8bc811ee5cf65b0bd0199cf66b4a51a50 SHA512 dc1a5e408515cb82004bf66bc014ebdd451eaea07d3543094cec494beb6d87165bdc0ac3672d6474a13d1918b1405507ee97ead05b9f1663789416b072aa6d6b
diff --git a/games-util/springlobby/springlobby-0.266.ebuild b/games-util/springlobby/springlobby-0.266.ebuild
new file mode 100644
index 000000000000..6fd4af3c6e07
--- /dev/null
+++ b/games-util/springlobby/springlobby-0.266.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER="3.0"
+inherit cmake-utils gnome2-utils wxwidgets
+
+DESCRIPTION="The official lobby client for SpringRTS community games"
+HOMEPAGE="https://springlobby.info"
+SRC_URI="https://www.springlobby.info/tarballs/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +libnotify +nls +sound"
+
+RDEPEND="
+ >=dev-libs/boost-1.35:=
+ dev-libs/openssl:=
+ net-misc/curl
+ sys-libs/zlib[minizip]
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXext
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ libnotify? ( x11-libs/libnotify )
+ sound? ( media-libs/alure
+ media-libs/openal
+ )
+"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ setup-wxwidgets
+ local mycmakeargs=(
+ -DOPTION_NOTIFY=$(usex libnotify)
+ -DOPTION_SOUND=$(usex sound)
+ -DOPTION_TRANSLATION_SUPPORT=$(usex nls)
+ -DAUX_VERSION="(Gentoo,${ARCH})"
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}