summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-06-29 18:05:30 -0500
committerAustin English <wizardedit@gentoo.org>2016-06-29 18:05:30 -0500
commitaab599ebe4c129829468303881ca71a29e93d223 (patch)
tree9df2963f896f12ba3523e3dc7d751792743ba493 /games-util
parentgames-util/gslist: remove depreacted games eclass (diff)
downloadgentoo-aab599ebe4c129829468303881ca71a29e93d223.tar.gz
gentoo-aab599ebe4c129829468303881ca71a29e93d223.tar.bz2
gentoo-aab599ebe4c129829468303881ca71a29e93d223.zip
games-util/gamepick: remove depreacted games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.2.28
Diffstat (limited to 'games-util')
-rw-r--r--games-util/gamepick/gamepick-0.35-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-util/gamepick/gamepick-0.35-r1.ebuild b/games-util/gamepick/gamepick-0.35-r1.ebuild
new file mode 100644
index 000000000000..6271a2f4a49f
--- /dev/null
+++ b/games-util/gamepick/gamepick-0.35-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Launch opengl games with custom graphic settings"
+HOMEPAGE="http://www.rillion.net/gamepick/index.html"
+SRC_URI="http://www.rillion.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's/-O2//' \
+ src/Makefile.in || die
+}
+
+src_install() {
+ default
+ newicon ${PN}-48x48.xpm ${PN}.xpm
+ make_desktop_entry ${PN} ${PN}
+}