summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-04-10 15:00:55 +0300
committerMart Raudsepp <leio@gentoo.org>2019-04-10 15:04:18 +0300
commit65ffecb8853c686b6c979e71ac2fbf466b2f931a (patch)
tree5c5da24d6eb8f1b4ddffb367fc79d55c92ef34cc /gnome-extra
parentgnome-extra/nemo: remove old (diff)
downloadgentoo-65ffecb8853c686b6c979e71ac2fbf466b2f931a.tar.gz
gentoo-65ffecb8853c686b6c979e71ac2fbf466b2f931a.tar.bz2
gentoo-65ffecb8853c686b6c979e71ac2fbf466b2f931a.zip
gnome-extra/nemo-3.8: use tracker-2
I am trying to remove tracker-1 subslot from tree, so patch nemo-3.8 to support tracker-2 too, as I don't want to remove all of cinnamon 3.8 set just for that (and only removing 3.8 doesn't make sense). Remove bogus LA_PUNT and unnecessary src_prepare while here. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/nemo/nemo-3.8.6-r1.ebuild (renamed from gnome-extra/nemo/nemo-3.8.6.ebuild)9
-rw-r--r--gnome-extra/nemo/nemo-4.0.6.ebuild7
2 files changed, 4 insertions, 12 deletions
diff --git a/gnome-extra/nemo/nemo-3.8.6.ebuild b/gnome-extra/nemo/nemo-3.8.6-r1.ebuild
index c4ae41b45371..4ddc41997b43 100644
--- a/gnome-extra/nemo/nemo-3.8.6.ebuild
+++ b/gnome-extra/nemo/nemo-3.8.6-r1.ebuild
@@ -2,8 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_COMPAT=( python3_{5,6} )
inherit meson eutils gnome2 python-any-r1 virtualx
@@ -34,7 +33,7 @@ COMMON_DEPEND="
exif? ( >=media-libs/libexif-0.6.20:= )
introspection? ( >=dev-libs/gobject-introspection-0.6.4:= )
- tracker? ( >=app-misc/tracker-0.12:0/100 )
+ tracker? ( >=app-misc/tracker-0.12:= )
xmp? ( >=media-libs/exempi-2.2.0:= )
selinux? ( sys-libs/libselinux )
"
@@ -65,9 +64,7 @@ DEPEND="${COMMON_DEPEND}
# For eautoreconf
# gnome-base/gnome-common, dev-util/gtk-doc (not only -am!)
-src_prepare() {
- gnome2_src_prepare
-}
+PATCHES=( "${FILESDIR}"/tracker-2.patch ) # https://github.com/linuxmint/nemo/issues/2065
src_configure() {
meson_src_configure \
diff --git a/gnome-extra/nemo/nemo-4.0.6.ebuild b/gnome-extra/nemo/nemo-4.0.6.ebuild
index 80cd39e0275d..4aa693cf74b4 100644
--- a/gnome-extra/nemo/nemo-4.0.6.ebuild
+++ b/gnome-extra/nemo/nemo-4.0.6.ebuild
@@ -2,8 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_COMPAT=( python3_{5,6} )
inherit meson eutils gnome2 python-any-r1 virtualx
@@ -67,10 +66,6 @@ DEPEND="${COMMON_DEPEND}
PATCHES=( "${FILESDIR}"/tracker-2.patch ) # https://github.com/linuxmint/nemo/issues/2065
-src_prepare() {
- gnome2_src_prepare
-}
-
src_configure() {
meson_src_configure \
-Dexif=$(usex exif true false) \