summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnustep-apps/textedit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnustep-apps/textedit')
-rw-r--r--gnustep-apps/textedit/Manifest1
-rw-r--r--gnustep-apps/textedit/files/textedit-0.95_pre20100427-gcc47.patch20
-rw-r--r--gnustep-apps/textedit/files/textedit-0.95_pre20100427-nsinvalidargument.patch26
-rw-r--r--gnustep-apps/textedit/metadata.xml10
-rw-r--r--gnustep-apps/textedit/textedit-0.95_pre20100427-r1.ebuild22
-rw-r--r--gnustep-apps/textedit/textedit-0.95_pre20100427.ebuild21
6 files changed, 100 insertions, 0 deletions
diff --git a/gnustep-apps/textedit/Manifest b/gnustep-apps/textedit/Manifest
new file mode 100644
index 000000000000..06fe05ee4ceb
--- /dev/null
+++ b/gnustep-apps/textedit/Manifest
@@ -0,0 +1 @@
+DIST textedit-0.95_pre20100427.tar.gz 131332 SHA256 a5f1fa0bf9d1f3c5b038e7696120eac4d2c22dd19876ca0fafe056929881e89a SHA512 df46ce1d0eb61ee776a0c4318f743f365d4d632ec0bbf9d04d1e6afbd35456f4a396fcafcac70e924475ccb2bb8dbbbf7dea18a68014f9634212c2803db59596 WHIRLPOOL 85c3780df2e03c6a80951dc0f59c6d66847e8aaa71d9825420a9566dceab917d1b6f66f3a865f4988c1f85b290fdd67cabb8fc2281817bd92b241931f7ab7942
diff --git a/gnustep-apps/textedit/files/textedit-0.95_pre20100427-gcc47.patch b/gnustep-apps/textedit/files/textedit-0.95_pre20100427-gcc47.patch
new file mode 100644
index 000000000000..b2a0bfedcd3c
--- /dev/null
+++ b/gnustep-apps/textedit/files/textedit-0.95_pre20100427-gcc47.patch
@@ -0,0 +1,20 @@
+--- textedit.app-4.0+20061029.orig/Document.m
++++ textedit.app-4.0+20061029/Document.m
+@@ -1361,13 +1361,13 @@ validateToggleItem (NSMenuItem *aCell, B
+ {
+ SEL action = [aCell action];
+ #ifdef GNUSTEP
+- const char *sel_name = sel_get_name (action);
++ const char *sel_name = sel_getName (action);
+
+- if (!strcmp (sel_name, sel_get_name (@selector (toggleRich:)))) {
++ if (!strcmp (sel_name, sel_getName (@selector (toggleRich:)))) {
+ validateToggleItem (aCell, [self isRichText], _(@"&Make Plain Text"), _(@"&Make Rich Text"));
+- } else if (!strcmp (sel_name, sel_get_name (@selector (togglePageBreaks:)))) {
++ } else if (!strcmp (sel_name, sel_getName (@selector (togglePageBreaks:)))) {
+ validateToggleItem (aCell, [self hasMultiplePages], _(@"&Wrap to Window"), _(@"&Wrap to Page"));
+- } else if (!strcmp (sel_name, sel_get_name (@selector (toggleHyphenation:)))) {
++ } else if (!strcmp (sel_name, sel_getName (@selector (toggleHyphenation:)))) {
+ if (!hyphenationSupported()) // Disable it
+ return NO;
+ validateToggleItem (aCell, ([self hyphenationFactor] > 0.0), _(@"Disallow &Hyphenation"), _(@"Allow &Hyphenation"));
diff --git a/gnustep-apps/textedit/files/textedit-0.95_pre20100427-nsinvalidargument.patch b/gnustep-apps/textedit/files/textedit-0.95_pre20100427-nsinvalidargument.patch
new file mode 100644
index 000000000000..345a0641fcbc
--- /dev/null
+++ b/gnustep-apps/textedit/files/textedit-0.95_pre20100427-nsinvalidargument.patch
@@ -0,0 +1,26 @@
+--- textedit.app-4.0+20061029.orig/Document.m
++++ textedit.app-4.0+20061029/Document.m
+@@ -124,12 +124,6 @@
+ [self setViewSize: size];
+ }
+
+- [[NSNotificationCenter defaultCenter]
+- addObserver: self
+- selector: @selector (fixUpScrollViewBackgroundColor:)
+- name: NSSystemColorsDidChangeNotification
+- object: nil];
+-
+ potentialSaveDirectory = nil;
+ return self;
+ }
+@@ -195,10 +189,6 @@
+ NSNotificationCenter *center = [NSNotificationCenter defaultCenter];
+
+ [center removeObserver: self
+- name: NSSystemColorsDidChangeNotification
+- object: nil];
+-
+- [center removeObserver: self
+ name: NSTextStorageDidProcessEditingNotification
+ object: [self textStorage]];
+
diff --git a/gnustep-apps/textedit/metadata.xml b/gnustep-apps/textedit/metadata.xml
new file mode 100644
index 000000000000..875567b4baee
--- /dev/null
+++ b/gnustep-apps/textedit/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnustep</herd>
+<longdescription>
+TextEdit
+
+This directory contains the source code for the TextEdit demo, which is a simple text editor.
+</longdescription>
+</pkgmetadata>
diff --git a/gnustep-apps/textedit/textedit-0.95_pre20100427-r1.ebuild b/gnustep-apps/textedit/textedit-0.95_pre20100427-r1.ebuild
new file mode 100644
index 000000000000..7aa7ecc9e00d
--- /dev/null
+++ b/gnustep-apps/textedit/textedit-0.95_pre20100427-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnustep-2
+
+S=${WORKDIR}/TextEdit
+
+DESCRIPTION="A text editor with font, color, and style capabilities for GNUstep"
+HOMEPAGE="http://www.nongnu.org/backbone/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+KEYWORDS="amd64 ~ppc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc47.patch
+ epatch "${FILESDIR}"/${P}-nsinvalidargument.patch
+}
diff --git a/gnustep-apps/textedit/textedit-0.95_pre20100427.ebuild b/gnustep-apps/textedit/textedit-0.95_pre20100427.ebuild
new file mode 100644
index 000000000000..9b5d9583643d
--- /dev/null
+++ b/gnustep-apps/textedit/textedit-0.95_pre20100427.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+inherit eutils gnustep-2
+
+S=${WORKDIR}/TextEdit
+
+DESCRIPTION="A text editor with font, color, and style capabilities for GNUstep"
+HOMEPAGE="http://www.nongnu.org/backbone/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+KEYWORDS="amd64 ~ppc x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc47.patch
+}