summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-07 00:11:27 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-07 13:59:58 +0100
commit7f45ce7728de31bb839db16ab19319f026ab0add (patch)
tree460a42bf534d6aa491db847a52a3026e3758c161 /kde-apps/akonadi
parentkde-apps/gwenview: Backport exiv2-0.27 support to 18.08.3 (diff)
downloadgentoo-7f45ce7728de31bb839db16ab19319f026ab0add.tar.gz
gentoo-7f45ce7728de31bb839db16ab19319f026ab0add.tar.bz2
gentoo-7f45ce7728de31bb839db16ab19319f026ab0add.zip
kde-apps: Add KDE Applications 18.12.2
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/akonadi')
-rw-r--r--kde-apps/akonadi/Manifest1
-rw-r--r--kde-apps/akonadi/akonadi-18.12.2.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/kde-apps/akonadi/Manifest b/kde-apps/akonadi/Manifest
index c9eb4e9726ea..228bef10c157 100644
--- a/kde-apps/akonadi/Manifest
+++ b/kde-apps/akonadi/Manifest
@@ -1,2 +1,3 @@
DIST akonadi-18.08.3.tar.xz 1538188 BLAKE2B 333c86802418f86f2336408d1e63ce16a9fc50267f7d5cb39f177eb6aab1ddc8479fa9384f323f8aad0ac4157d8abfe8de237bcc6bd058b19fe596442c7f20e1 SHA512 ba883902ad83c989bb480712c0b3871e683307ecb121f1d7b3e433b9211056cda209d9640a7bae520fb4b6611950863180b879269797a606af2ac25ae4f24cc0
DIST akonadi-18.12.1.tar.xz 1552724 BLAKE2B 7e47c48ecbc25b450df9cffabb6b019003f03a66c5fc214db0d183085b9dd9fbbd8443fb6906837e85d3e554a0d603f8e657db8ddf6bb5795a055f9f51b84aac SHA512 9d20f4b283c00f20a0b3c1a40041bb5b1adff6197fef5d6bc12ff7ea013de2809bafa3ffac0f70494b659e5972bc00f73e7df9d7d3d3157deabbebad5811c5ec
+DIST akonadi-18.12.2.tar.xz 1553596 BLAKE2B 7b5378cad08f858a51315d624bf83a6ad2a09af11f288a0009461449ba9e3f3118dd0fbd22b8f99c78c70dd486e2e70f89f6cc58b39d95481b58852dc2bbd4cc SHA512 a78ac757452360252eac2fcafbc01dcc5c84756db16da89c29c7ee8d7fa6deef3bc5b5bc1101c5e99e68b260fcdf1f96a780bef19b7d07198d4c00e546224431
diff --git a/kde-apps/akonadi/akonadi-18.12.2.ebuild b/kde-apps/akonadi/akonadi-18.12.2.ebuild
new file mode 100644
index 000000000000..a4342c4ffe4f
--- /dev/null
+++ b/kde-apps/akonadi/akonadi-18.12.2.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_DESIGNERPLUGIN="true"
+KDE_TEST="forceoptional"
+VIRTUALDBUS_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Storage service for PIM data and libraries for PIM apps"
+HOMEPAGE="https://community.kde.org/KDE_PIM/akonadi"
+
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="LGPL-2.1+"
+IUSE="+mysql postgres sqlite tools xml"
+
+REQUIRED_USE="|| ( mysql postgres sqlite ) test? ( tools )"
+
+BDEPEND="
+ test? ( sys-apps/dbus )
+"
+COMMON_DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtsql 'mysql?,postgres?')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ sqlite? (
+ $(add_qt_dep qtsql 'sqlite' '' '5=')
+ dev-db/sqlite:3
+ )
+ xml? ( dev-libs/libxml2 )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost
+ dev-libs/libxslt
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-apps/akonadi:4
+ !<kde-apps/kapptemplate-17.11.80
+ !kde-apps/kdepim-l10n
+ !kde-apps/kdepimlibs
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql )
+"
+
+# some akonadi tests time out, that probably needs more work as it's ~700 tests
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}/${PN}-18.12.2-mysql56-crash.patch" )
+
+pkg_setup() {
+ # Set default storage backend in order: MySQL, PostgreSQL, SQLite
+ # reverse driver check to keep the order
+ use sqlite && DRIVER="QSQLITE3"
+ use postgres && DRIVER="QPSQL"
+ use mysql && DRIVER="QMYSQL"
+
+ if use sqlite || has_version "<${CATEGORY}/${P}[sqlite]"; then
+ ewarn "We strongly recommend you change your Akonadi database backend to either MySQL"
+ ewarn "or PostgreSQL in your user configuration."
+ ewarn "In particular, kde-apps/kmail does not work properly with the sqlite backend."
+ fi
+
+ kde5_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DAKONADI_BUILD_QSQLITE=$(usex sqlite)
+ -DBUILD_TOOLS=$(usex tools)
+ $(cmake-utils_use_find_package xml LibXml2)
+ )
+
+ kde5_src_configure
+}
+
+src_install() {
+ # Who knows, maybe it accidentally fixes our permission issues
+ cat <<-EOF > "${T}"/akonadiserverrc
+[%General]
+Driver=${DRIVER}
+EOF
+ insinto /usr/share/config/akonadi
+ doins "${T}"/akonadiserverrc
+
+ kde5_src_install
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ elog "You can select the storage backend in ~/.config/akonadi/akonadiserverrc."
+ elog "Available drivers are:"
+ use mysql && elog " QMYSQL"
+ use postgres && elog " QPSQL"
+ use sqlite && elog " QSQLITE3"
+ elog "${DRIVER} has been set as your default akonadi storage backend."
+}