summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-11-09 20:09:00 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-11-09 20:18:28 +0100
commit0e8f2a31161f9138b1731358e9e567b244c6d3d5 (patch)
tree867a9206117086871e741c4956b66e2bdb621dc4 /kde-apps/ark
parentwww-client/qupzilla: 2.2.1 version bump (diff)
downloadgentoo-0e8f2a31161f9138b1731358e9e567b244c6d3d5.tar.gz
gentoo-0e8f2a31161f9138b1731358e9e567b244c6d3d5.tar.bz2
gentoo-0e8f2a31161f9138b1731358e9e567b244c6d3d5.zip
kde-apps: Add KDE Applications 17.08.3
Package-Manager: Portage-2.3.8, Repoman-2.3.4
Diffstat (limited to 'kde-apps/ark')
-rw-r--r--kde-apps/ark/Manifest1
-rw-r--r--kde-apps/ark/ark-17.08.3.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/kde-apps/ark/Manifest b/kde-apps/ark/Manifest
index d32c9af465d5..1674b7a479c3 100644
--- a/kde-apps/ark/Manifest
+++ b/kde-apps/ark/Manifest
@@ -1,2 +1,3 @@
DIST ark-17.04.3.tar.xz 1888304 SHA256 36ea400aa72ee3e8ec09c3ef2a0ffc5dad6b4afb34aa0c0736a885f4635333ad SHA512 58e3c5060381f59af2ec9ede0beefc2da6349701415c591fe568c16f30b7e5f95ce5cbeb14ca1d995f5968ea68d23593ed37c4f6ea54e77faff5a97d7a3efed0 WHIRLPOOL 3335e272eb009a12e2ea50f0a8aa17d1e1599517788814ac6fcc8b3323c66f5442d74b0b54ee22f29d26d37f66c5fb3353074eb4fd42ad5168829423eaa09cd8
DIST ark-17.08.2.tar.xz 1965692 SHA256 224d182df6d11eb2453887e0972f3b60a5177b1c89eac52661a470a7bff1c3d7 SHA512 060d4b17d191bb87c99c44452544dea936c5dcc40a8f71f29aaea37a0fd9d526d14510a5a4fb42d8794d9d8b640bf6773369b8647ce017082efa9ba580f4f0bf WHIRLPOOL cfbc56d56999b0c725f5dd2174fbfff694de4699d272c8903c928dd0ef5f363a958f543aec7f45e0eaec99dd92fefcb4c02b4d6c6b068cb78ef6c52958bbeea0
+DIST ark-17.08.3.tar.xz 1966132 SHA256 dd206ae58946f451d16b5369376b2fe46fa1e6d19d95637aa3a40fd1ec18e3e3 SHA512 c28eda02f561391a21723286de2b71b9d985a07edfabd510b690927ac598da7464b56ba6132bb0362a6fd7ddb35d99bcbeb8ef74b801cfbba22f6f6d91262fb8 WHIRLPOOL 35de7267080b1d3de90135a55421a25ff6280cb7ff2b5bbcbaa5046f963251b3058f3c15355b960e1d66eaaf985a3f3f3fd408fd7095ec198b79bbec5575c7bd
diff --git a/kde-apps/ark/ark-17.08.3.ebuild b/kde-apps/ark/ark-17.08.3.ebuild
new file mode 100644
index 000000000000..b40db618e929
--- /dev/null
+++ b/kde-apps/ark/ark-17.08.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Archiving tool"
+HOMEPAGE="https://www.kde.org/applications/utilities/ark
+https://utils.kde.org/projects/ark/"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 lzma zip zlib"
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ app-arch/libarchive:=[bzip2?,lzma?,zlib?]
+ zip? ( >=dev-libs/libzip-1.2.0:= )
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep qtconcurrent)
+ sys-devel/gettext
+"
+
+# bug #560548, last checked with 16.04.1
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package bzip2 BZip2)
+ $(cmake-utils_use_find_package lzma LibLZMA)
+ $(cmake-utils_use_find_package zip LibZip)
+ $(cmake-utils_use_find_package zlib ZLIB)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ # not a typo, app-arch/unar is a real package
+ if ! has_version app-arch/unar ; then
+ elog "For handling rar archives, install app-arch/unar"
+ fi
+
+ if ! has_version app-arch/p7zip ; then
+ elog "For handling 7-Zip archives, install app-arch/p7zip"
+ fi
+
+ if ! has_version app-arch/lrzip ; then
+ elog "For handling lrz archives, install app-arch/lrzip"
+ fi
+}