summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-07 19:18:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-07 19:18:36 +0200
commit2fb79a4076772020c18be0215abb7a430ac12b3b (patch)
tree02e6972566d0e4e18611dfd81121657a95919e66 /kde-apps/cantor
parentdev-libs/libinput: Restore version 1.10.6 (diff)
downloadgentoo-2fb79a4076772020c18be0215abb7a430ac12b3b.tar.gz
gentoo-2fb79a4076772020c18be0215abb7a430ac12b3b.tar.bz2
gentoo-2fb79a4076772020c18be0215abb7a430ac12b3b.zip
kde-apps: Add KDE Applications 18.04.2
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'kde-apps/cantor')
-rw-r--r--kde-apps/cantor/Manifest1
-rw-r--r--kde-apps/cantor/cantor-18.04.2.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/kde-apps/cantor/Manifest b/kde-apps/cantor/Manifest
index 3eb1ab4d7fd0..5ccb30877311 100644
--- a/kde-apps/cantor/Manifest
+++ b/kde-apps/cantor/Manifest
@@ -1,2 +1,3 @@
DIST cantor-17.12.3.tar.xz 1066992 BLAKE2B fdaaa42adf45b3013337374b83b6da77d6adfd610e233d56a80965f35f3433b412d4f1279a3c2c3e257a57a69b44d7e190f42e325f0fd3fa5ef4223ce6ddbfb7 SHA512 37d080fa3e87cbd105e33c687b5bc670c0833639873c41e1dcc519577103186ec629c85b5a1875af915267eb7ca3d13f170894bb9c0c882c964ccc02a24cfa3b
DIST cantor-18.04.1.tar.xz 1070188 BLAKE2B a5a6dbae3305b00f9f9160e1ab9680e40fadc0bc67020235188c09dc35d5b7a271858746a918c100be9bf180a7aff0bcb728d5a60dfec7ae007fe0c075ec07c3 SHA512 7a5e01ef920f24587009cd58e27428c4e6686250af5a2a0449f95efd6b994d054cf32c9eaa78716b940f9073b04fa0086e6207bb7a30934d1c9f2fcad98fa311
+DIST cantor-18.04.2.tar.xz 1071952 BLAKE2B fcccf731040f49229ba43e5cf00a052f8e7d93736536c63a9b92c93423794e927ea295f292295f2f6ed5844fc3bdf08367907439f3ef9e47900549c8bf6f2c63 SHA512 40b57c65606c771f96d8439eb192436dab7eca126a6d9e6d0b985aff3f11b340e4e3f42c182bceb5f954d2e695f8e13b739685d6c4389fdbcc07a4e99a936d40
diff --git a/kde-apps/cantor/cantor-18.04.2.ebuild b/kde-apps/cantor/cantor-18.04.2.ebuild
new file mode 100644
index 000000000000..cd2bf41394b4
--- /dev/null
+++ b/kde-apps/cantor/cantor-18.04.2.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+PYTHON_COMPAT=( python2_7 )
+# FIXME: PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit kde5 python-r1
+
+DESCRIPTION="Interface for doing mathematics and scientific computing"
+HOMEPAGE="https://www.kde.org/applications/education/cantor https://edu.kde.org/cantor/"
+KEYWORDS="~amd64 ~x86"
+IUSE="+analitza julia lua postscript python qalculate R"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
+# FIXME: $(python_gen_cond_dep 'dev-qt/qtdbus:5' 'python3*')
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep ktexteditor)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ $(add_qt_dep qtxmlpatterns)
+ analitza? ( $(add_kdeapps_dep analitza) )
+ julia? ( dev-lang/julia )
+ lua? ( dev-lang/luajit:2 )
+ qalculate? (
+ sci-libs/cln
+ sci-libs/libqalculate:=
+ )
+ postscript? ( app-text/libspectre )
+ python? ( ${PYTHON_DEPS} )
+ R? ( dev-lang/R )
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT+=" test"
+
+pkg_pretend() {
+ kde5_pkg_pretend
+
+ if ! has_version sci-mathematics/maxima && ! has_version sci-mathematics/octave && \
+ ! use analitza && ! use julia && ! use lua && ! use python && ! use qalculate && ! use R; then
+ einfo "You have decided to build ${PN} with no backend."
+ einfo "To have this application functional, please enable one of the backends via USE flag:"
+ einfo " analitza, lua, python, qalculate"
+ einfo "Alternatively, install one of these:"
+ einfo " # emerge sci-mathematics/maxima (bug #619534)"
+ einfo " # emerge sci-mathematics/octave"
+ einfo "Experimental available USE flags:"
+ einfo " julia (not stable, bug #613576), R (bug #619534)"
+ einfo
+ fi
+
+ if ! has_version virtual/latex-base; then
+ einfo "For LaTeX support:"
+ einfo " # emerge virtual/latex-base"
+ fi
+}
+
+pkg_setup() {
+ use python && python_setup
+ kde5_pkg_setup
+}
+
+src_prepare() {
+ kde5_src_prepare
+
+ # FIXME: shipped FindPythonLibs3.cmake does not work for Gentoo
+ sed -e "/^find_package(PythonLibs3)/ s/^/#/" \
+ -i src/backends/CMakeLists.txt || die
+}
+
+src_configure() {
+ use julia && addpredict /proc/self/mem # bug 602894
+
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package analitza Analitza5)
+ $(cmake-utils_use_find_package julia Julia)
+ $(cmake-utils_use_find_package lua LuaJIT)
+ $(cmake-utils_use_find_package postscript LibSpectre)
+ $(cmake-utils_use_find_package python PythonLibs)
+ $(cmake-utils_use_find_package qalculate Qalculate)
+ $(cmake-utils_use_find_package R R)
+ )
+ kde5_src_configure
+}