summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-03-20 18:15:30 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-03-26 01:47:48 +1100
commit19b3e9cf70fee6f2c335138da31ff3f4b5f6f483 (patch)
tree9053ad6d36968164763c1a5faf3aa8de7df40500 /kde-apps/kalzium/kalzium-15.12.3-r2.ebuild
parentx11-drivers/xf86-video-intel: Update snapshot (diff)
downloadgentoo-19b3e9cf70fee6f2c335138da31ff3f4b5f6f483.tar.gz
gentoo-19b3e9cf70fee6f2c335138da31ff3f4b5f6f483.tar.bz2
gentoo-19b3e9cf70fee6f2c335138da31ff3f4b5f6f483.zip
kde-apps/kalzium: Re-add USE=+plasma, fix DEPENDs
Package-Manager: portage-2.2.27
Diffstat (limited to 'kde-apps/kalzium/kalzium-15.12.3-r2.ebuild')
-rw-r--r--kde-apps/kalzium/kalzium-15.12.3-r2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/kde-apps/kalzium/kalzium-15.12.3-r2.ebuild b/kde-apps/kalzium/kalzium-15.12.3-r2.ebuild
new file mode 100644
index 000000000000..30195903c7f5
--- /dev/null
+++ b/kde-apps/kalzium/kalzium-15.12.3-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="always"
+inherit kde4-base flag-o-matic
+
+DESCRIPTION="KDE: periodic table of the elements"
+HOMEPAGE="https://www.kde.org/applications/education/kalzium
+https://edu.kde.org/kalzium"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="debug editor +plasma solver"
+
+DEPEND="
+ editor? (
+ dev-cpp/eigen:3
+ sci-chemistry/avogadro
+ >=sci-chemistry/openbabel-2.2
+ dev-qt/qtopengl:4
+ )
+ solver? ( dev-ml/facile[ocamlopt] )
+"
+RDEPEND="${DEPEND}
+ sci-chemistry/chemical-mime-data
+"
+
+PATCHES=( "${FILESDIR}/${PN}-15.12.3-plasmoids.patch" )
+
+src_configure(){
+ # Fix missing finite()
+ [[ ${CHOST} == *-solaris* ]] && append-cppflags -DHAVE_IEEEFP_H
+
+ local mycmakeargs=(
+ $(cmake-utils_use_build plasma plasmoid)
+ $(cmake-utils_use_with editor Eigen3)
+ $(cmake-utils_use_with editor Avogadro)
+ $(cmake-utils_use_with editor OpenBabel2)
+ $(cmake-utils_use_with solver OCaml)
+ $(cmake-utils_use_with solver Libfacile)
+ )
+
+ kde4-base_src_configure
+}