summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-12 12:11:22 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-12 12:55:47 +0100
commit4d39b7fcd55a1dfd4186b4d303c0c56a6732ad93 (patch)
tree0025a9290bf044c691a09ea8336c6d3795d1cce2 /kde-apps/kross-interpreters
parentdev-python/mpmath: bump to 1.1.0 (diff)
downloadgentoo-4d39b7fcd55a1dfd4186b4d303c0c56a6732ad93.tar.gz
gentoo-4d39b7fcd55a1dfd4186b4d303c0c56a6732ad93.tar.bz2
gentoo-4d39b7fcd55a1dfd4186b4d303c0c56a6732ad93.zip
kde-apps/kross-interpreters: Switch to ruby24
Closes: https://bugs.gentoo.org/672982 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kross-interpreters')
-rw-r--r--kde-apps/kross-interpreters/kross-interpreters-18.08.3-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/kde-apps/kross-interpreters/kross-interpreters-18.08.3-r1.ebuild b/kde-apps/kross-interpreters/kross-interpreters-18.08.3-r1.ebuild
new file mode 100644
index 000000000000..38f4ee94df97
--- /dev/null
+++ b/kde-apps/kross-interpreters/kross-interpreters-18.08.3-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+USE_RUBY="ruby24"
+inherit kde5 python-single-r1 ruby-single
+
+DESCRIPTION="Kross interpreter plugins for programming languages"
+KEYWORDS="amd64 x86"
+IUSE="+python ruby"
+
+REQUIRED_USE="|| ( python ruby ) python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ $(add_frameworks_dep kross)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ python? ( ${PYTHON_DEPS} )
+ ruby? ( ${RUBY_DEPS} )
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+ kde5_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_python=$(usex python)
+ -DBUILD_ruby=$(usex ruby)
+ )
+
+ kde5_src_configure
+}