summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-02-09 19:42:23 +0100
committerJohannes Huber <johu@gentoo.org>2017-02-09 19:42:37 +0100
commit0e7c442531fd2caefa9035ffc99514dc94432083 (patch)
tree7a07bfea1f2927843db5bef673bb696eac1a32a6 /kde-apps/print-manager
parentmultiprocess.eclass: makeopts_{jobs,loadavg}: fix implicit handling of $MAKEO... (diff)
downloadgentoo-0e7c442531fd2caefa9035ffc99514dc94432083.tar.gz
gentoo-0e7c442531fd2caefa9035ffc99514dc94432083.tar.bz2
gentoo-0e7c442531fd2caefa9035ffc99514dc94432083.zip
kde-apps: Version bump KDE Applications 16.12.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-apps/print-manager')
-rw-r--r--kde-apps/print-manager/Manifest1
-rw-r--r--kde-apps/print-manager/print-manager-16.12.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/kde-apps/print-manager/Manifest b/kde-apps/print-manager/Manifest
index f91c4e3142fe..ddca461d7910 100644
--- a/kde-apps/print-manager/Manifest
+++ b/kde-apps/print-manager/Manifest
@@ -1,2 +1,3 @@
DIST print-manager-16.08.3.tar.xz 94220 SHA256 7d99d4fc4264a1a3eb50dba2cfe57c41513325dc530ee3f6e18e47f1bd3c6d1d SHA512 2952eca590aa8928f8931dd0531f861f7e285a59a2600e7c79ee8f2b00b23eb3f9114176c30462fb9cbd63f24f4227ba0bdfffce78ae8c32088a04e2270d89f4 WHIRLPOOL 7b7b37f7dcab2ee2f35a4c93a92a396aecf0ebdb6b8526a3cfe2ffdfe93df12d7993fe8ca691eb88261b48b04676a3167880fad10933d41bfba4c419e006c54b
DIST print-manager-16.12.1.tar.xz 94252 SHA256 c6ff691baf96768596252dfcff70e2996c0fa401b634d3e34bdce4e1c3699aef SHA512 b3851ab38c0d36f7a31df092cc39ee0952536dabd53d396ef8c6d402d98284ce31e3f367eebb5cf22abb1144091a9acb719c1c1bf141784ff891e0760f538f98 WHIRLPOOL f28813435848a57b98f3f0808a38f3d8c000ceefb377a62f3d596040d8022495499641253b2a7c5c78d0921122d479cbe0086e26c9ab0eb86ff7d7f25d15fb13
+DIST print-manager-16.12.2.tar.xz 94256 SHA256 7cf1ff29e8dab93ef11a68cef394af09c205e68b1b660f9d0cbfc46347a0b0aa SHA512 1df8ca29a7a5862f239dec0d58385ac81c52b8b38ddac787e2442390317db24228d509c15e025175abe0f12b78995d8382b48aefbb96fda49d0bac1d4b1b807e WHIRLPOOL 76b1b6ed1d9c95e507c5bdcdf9735c229ade9be38a5236978b0c843c1e07c9618967cb209d003c3305a4910590575a8013e9f33227515c635c49d46792dfe507
diff --git a/kde-apps/print-manager/print-manager-16.12.2.ebuild b/kde-apps/print-manager/print-manager-16.12.2.ebuild
new file mode 100644
index 000000000000..9804b9f55247
--- /dev/null
+++ b/kde-apps/print-manager/print-manager-16.12.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Manage print jobs and printers in Plasma"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gtk"
+
+DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep plasma)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ net-print/cups
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ gtk? ( app-admin/system-config-printer )
+"
+
+pkg_postinst(){
+ if ! use gtk ; then
+ ewarn
+ ewarn "By switching off \"gtk\" USE flag, you have chosen to do without"
+ ewarn "an important, though optional, runtime dependency:"
+ ewarn
+ ewarn "app-admin/system-config-printer"
+ ewarn
+ ewarn "${PN} will work nevertheless, but is going to be less comfortable"
+ ewarn "and will show the following error status during runtime:"
+ ewarn
+ ewarn "\"Failed to group devices: 'The name org.fedoraproject.Config.Printing"
+ ewarn "was not provided by any .service files'\""
+ ewarn
+ fi
+}