summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-03-20 18:15:30 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-03-26 00:11:58 +1100
commitb0db5d580b55bd526d8c5f47a48bc2cb0b641b1f (patch)
tree499e18b5c2706f317beb84a22b66d1a205c70567 /kde-apps/rocs/rocs-15.12.3.ebuild
parentkde-apps/kblocks: Drop old (diff)
downloadgentoo-b0db5d580b55bd526d8c5f47a48bc2cb0b641b1f.tar.gz
gentoo-b0db5d580b55bd526d8c5f47a48bc2cb0b641b1f.tar.bz2
gentoo-b0db5d580b55bd526d8c5f47a48bc2cb0b641b1f.zip
kde-apps: Move kdeedu-meta 15.12.3 from kde overlay
Package-Manager: portage-2.2.27
Diffstat (limited to 'kde-apps/rocs/rocs-15.12.3.ebuild')
-rw-r--r--kde-apps/rocs/rocs-15.12.3.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/kde-apps/rocs/rocs-15.12.3.ebuild b/kde-apps/rocs/rocs-15.12.3.ebuild
new file mode 100644
index 000000000000..2027eea46fda
--- /dev/null
+++ b/kde-apps/rocs/rocs-15.12.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+CMAKE_MIN_VERSION="3.0.0"
+KDE_HANDBOOK="optional"
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="Interface to work with Graph Theory"
+HOMEPAGE="https://www.kde.org/applications/education/rocs
+https://edu.kde.org/applications/mathematics/rocs"
+KEYWORDS=" ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktexteditor)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdeclarative 'widgets')
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtscript 'scripttools')
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwebkit)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ $(add_qt_dep qtxmlpatterns)
+ dev-libs/grantlee:5
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.49
+"
+
+RESTRICT=test # 1/10 tests currently fails
+
+PATCHES=( "${FILESDIR}/${P}-doctools-optional.patch" )