summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-08 19:48:53 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-08 22:04:29 +0100
commit891bb43b528502dc74af6e96996205b0772751ec (patch)
tree45d610c45e0dd9a7341413956110d4e279751235 /kde-apps
parentnet-vpn/vpnc: Use virtual/resolvconf dependency. (diff)
downloadgentoo-891bb43b528502dc74af6e96996205b0772751ec.tar.gz
gentoo-891bb43b528502dc74af6e96996205b0772751ec.tar.bz2
gentoo-891bb43b528502dc74af6e96996205b0772751ec.zip
games-board/knights: pkgmove to kde-apps/knights
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/knights/Manifest1
-rw-r--r--kde-apps/knights/knights-2.6.0_pre20180415.ebuild49
-rw-r--r--kde-apps/knights/metadata.xml15
3 files changed, 65 insertions, 0 deletions
diff --git a/kde-apps/knights/Manifest b/kde-apps/knights/Manifest
new file mode 100644
index 000000000000..935e3998cf44
--- /dev/null
+++ b/kde-apps/knights/Manifest
@@ -0,0 +1 @@
+DIST knights-2.6.0_pre20180415.tar.gz 2642374 BLAKE2B 18648348eb4f9c34a37b0992d5b75a90fbb7fb1b6a7b23750bb57f11553d50a320e68dba303c6ec7fd394a0464341dd28fb8b404bb8ad1b9a92934b767a8183f SHA512 ce022463f9efecfed13fd101d958cd753ea1d167d6a6a70c8735afeccb49a6e9b9e5a4fa15ee7a5510a65eaa08fa0615da109793b7df4a50040d809393723145
diff --git a/kde-apps/knights/knights-2.6.0_pre20180415.ebuild b/kde-apps/knights/knights-2.6.0_pre20180415.ebuild
new file mode 100644
index 000000000000..4b3b233b6101
--- /dev/null
+++ b/kde-apps/knights/knights-2.6.0_pre20180415.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+COMMIT=56762d582d8a8543f50c293ff54d5ac5e546c2d9
+KDE_HANDBOOK="forceoptional"
+KDE_SELINUX_MODULE="games"
+inherit kde5 vcs-snapshot
+
+DESCRIPTION="Simple chess board based on KDE Frameworks"
+HOMEPAGE="https://www.linux-apps.com/content/show.php/Knights?content=122046"
+SRC_URI="https://github.com/KDE/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="speech"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kplotting)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep plasma)
+ $(add_kdeapps_dep libkdegames)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ speech? ( $(add_qt_dep qtspeech) )
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog "No chess engines are emerged by default! If you want a chess engine"
+ elog "to play with, you can emerge gnuchess or crafty."
+}
diff --git a/kde-apps/knights/metadata.xml b/kde-apps/knights/metadata.xml
new file mode 100644
index 000000000000..ec264f573891
--- /dev/null
+++ b/kde-apps/knights/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+ <use>
+ <flag name="speech">Enable text-to-speech support</flag>
+ </use>
+</pkgmetadata>