summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-21 21:04:19 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-21 21:06:29 +0200
commitffd2966656305699be08ad422e70e471fc84aaeb (patch)
tree9a97103a23f508aba585c683d9fcfa5b71d4c71d /kde-frameworks
parentsys-libs/glibc: Add small locale install hack for riscv (diff)
downloadgentoo-ffd2966656305699be08ad422e70e471fc84aaeb.tar.gz
gentoo-ffd2966656305699be08ad422e70e471fc84aaeb.tar.bz2
gentoo-ffd2966656305699be08ad422e70e471fc84aaeb.zip
kde-frameworks/solid: Fix USE udev dependency to virtual/libudev
Thanks-to: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/solid/solid-5.57.0-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/kde-frameworks/solid/solid-5.57.0-r1.ebuild b/kde-frameworks/solid/solid-5.57.0-r1.ebuild
new file mode 100644
index 000000000000..481500b18de7
--- /dev/null
+++ b/kde-frameworks/solid/solid-5.57.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Provider for platform independent hardware discovery, abstraction and management"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls udev"
+
+BDEPEND="
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+RDEPEND="
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ sys-fs/udisks:2
+ udev? ( virtual/libudev:= )
+"
+DEPEND="${RDEPEND}
+ test? ( $(add_qt_dep qtconcurrent) )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUDEV_DISABLED=$(usex !udev)
+ )
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]] && ! has_version "app-misc/media-player-info" ; then
+ elog "For media player support, install app-misc/media-player-info"
+ fi
+
+ use udev || ewarn "Building without udev support may cause unintended runtime problems in consumers."
+}