summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-03-15 18:54:31 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-05-06 23:29:53 +0200
commitf0cb8120801a7c7e878078da42202a636107e39c (patch)
treec8efe02e0edddd777e4cbf56fa92f1512bdbe801 /kde-misc/kio-locate
parentmedia-video/kamerka: Add KF5-based snapshot (diff)
downloadgentoo-f0cb8120801a7c7e878078da42202a636107e39c.tar.gz
gentoo-f0cb8120801a7c7e878078da42202a636107e39c.tar.bz2
gentoo-f0cb8120801a7c7e878078da42202a636107e39c.zip
kde-misc/kio-locate: Add KF5-based snapshot
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-misc/kio-locate')
-rw-r--r--kde-misc/kio-locate/files/kio-locate-0.5.3-kf5port.patch102
-rw-r--r--kde-misc/kio-locate/kio-locate-0.5.3-r1.ebuild34
-rw-r--r--kde-misc/kio-locate/metadata.xml8
3 files changed, 140 insertions, 4 deletions
diff --git a/kde-misc/kio-locate/files/kio-locate-0.5.3-kf5port.patch b/kde-misc/kio-locate/files/kio-locate-0.5.3-kf5port.patch
new file mode 100644
index 000000000000..986e8c6b0ee2
--- /dev/null
+++ b/kde-misc/kio-locate/files/kio-locate-0.5.3-kf5port.patch
@@ -0,0 +1,102 @@
+diff -Naur a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2010-03-07 02:38:40.000000000 +0800
++++ b/CMakeLists.txt 2015-10-19 19:28:48.185748034 +0800
+@@ -1,31 +1,38 @@
+ set(KDE_MIN_VERSION "4.4.0")
+-find_package(KDE4 4.4.0 REQUIRED)
+-include (KDE4Defaults)
++
++find_package(ECM 0.0.11 REQUIRED NO_MODULE)
++set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
++
++include(KDEInstallDirs)
++include(KDECMakeSettings)
++include(KDECompilerSettings)
++include(FeatureSummary)
++
++find_package(Qt5 REQUIRED COMPONENTS Widgets)
++find_package(KF5 REQUIRED COMPONENTS KDELibs4Support) #CoreAddons Solid
+
+ add_definitions(-DKDE_DEFAULT_DEBUG_AREA=7199)
+
+-include_directories( ${KDE4_INCLUDES} )
+-include_directories( ${KDE4_KIO_INCLUDES} )
+
+-macro_optional_add_subdirectory(doc)
+-macro_optional_add_subdirectory(po)
++add_subdirectory(doc)
++add_subdirectory(po)
+
+ set(kio_locate_PART_SRCS
+ pattern.cpp
+ kio_locate.cpp
+ locater.cpp)
+
+-kde4_add_ui_files(kio_locate_PART_SRCS
++qt5_wrap_ui(kio_locate_PART_SRCS
+ klocateconfigfilterwidget.ui
+ klocateconfiglocatewidget.ui
+ klocateconfigwidget.ui)
+
+-kde4_add_kcfg_files(kio_locate_PART_SRCS klocateconfig.kcfgc)
++kconfig_add_kcfg_files(kio_locate_PART_SRCS klocateconfig.kcfgc)
+
+-kde4_add_plugin(kio_locate ${kio_locate_PART_SRCS} ${kio_locate_PART_RCCS})
++add_library(kio_locate MODULE ${kio_locate_PART_SRCS} ${kio_locate_PART_RCCS})
+
+
+-target_link_libraries(kio_locate ${KDE4_KDE3SUPPORT_LIBS})
++target_link_libraries(kio_locate KF5::KDELibs4Support KF5::KIOCore)
+
+ install(TARGETS kio_locate DESTINATION ${PLUGIN_INSTALL_DIR} )
+
+diff -Naur a/doc/CMakeLists.txt b/doc/CMakeLists.txt
+--- a/doc/CMakeLists.txt 2010-03-12 01:49:04.000000000 +0800
++++ b/doc/CMakeLists.txt 2015-10-19 18:47:14.081029481 +0800
+@@ -1 +1 @@
+-macro_optional_add_subdirectory(en)
++add_subdirectory(en)
+diff -Naur a/kio_locate.cpp b/kio_locate.cpp
+--- a/kio_locate.cpp 2010-03-20 17:05:46.000000000 +0800
++++ b/kio_locate.cpp 2015-10-19 18:49:56.251128472 +0800
+@@ -290,7 +290,7 @@
+ void LocateProtocol::setUrl(const KUrl& url)
+ {
+ if (url.protocol() != "locater") {
+- QString pattern = KUrl::decode_string(url.url());
++ QString pattern = url.toString();
+ pattern = pattern.mid(url.protocol().length() + 1);
+
+ KUrl newUrl;
+@@ -371,7 +371,7 @@
+ /// \todo Is UDS_NAME used for anything in stat? If so we should
+ /// at least strip of the protocol part.
+ UDSEntry entry;
+- entry.insert(KIO::UDSEntry::UDS_NAME, url.decode_string(url.url()));
++ entry.insert(KIO::UDSEntry::UDS_NAME, url.toString());
+ entry.insert(KIO::UDSEntry::UDS_FILE_TYPE, isDir ? S_IFDIR : S_IFREG);
+ statEntry(entry);
+ finished();
+@@ -767,7 +767,7 @@
+
+ KConfigDialog *dialog = new KConfigDialog(0, "settings", KLocateConfig::self());
+ dialog->setFaceType(KPageDialog::List);
+- dialog->setCaption(i18n("Configure - kio-locate"));
++ dialog->setWindowTitle(i18n("Configure - kio-locate"));
+ dialog->setWindowIcon(SmallIcon("edit-find"));
+
+ Ui::KLocateConfigWidget w1;
+diff -Naur a/kio_locate.h b/kio_locate.h
+--- a/kio_locate.h 2010-03-20 17:05:46.000000000 +0800
++++ b/kio_locate.h 2015-10-19 18:51:19.908758859 +0800
+@@ -62,6 +62,10 @@
+ #include "locater.h"
+ #include "pattern.h"
+
++#include <KUrl>
++#include <kicon.h>
++#define KDE_EXPORT __attribute__ ((visibility("default")))
++
+ class QByteArray;
+ class KUrl;
+
diff --git a/kde-misc/kio-locate/kio-locate-0.5.3-r1.ebuild b/kde-misc/kio-locate/kio-locate-0.5.3-r1.ebuild
new file mode 100644
index 000000000000..3cceefcf0abe
--- /dev/null
+++ b/kde-misc/kio-locate/kio-locate-0.5.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="optional"
+inherit kde5
+
+DESCRIPTION="Locate KIO slave"
+HOMEPAGE="http://www.kde-apps.org/content/show.php/kio-locate?content=120965"
+SRC_URI="http://www.kde-apps.org/CONTENT/content-files/120965-${P}.tar.gz"
+# See also: https://github.com/reporter123/kio-locate/commits/master
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DOCS=( AUTHORS ChangeLog )
+
+PATCHES=(
+ "${FILESDIR}/${P}-gcc-4.7.patch"
+ "${FILESDIR}/${P}-kf5port.patch"
+)
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}
+ !kde-misc/kio-locate:4
+ sys-apps/mlocate
+"
diff --git a/kde-misc/kio-locate/metadata.xml b/kde-misc/kio-locate/metadata.xml
index 0cf59224b009..2fdbf33d963d 100644
--- a/kde-misc/kio-locate/metadata.xml
+++ b/kde-misc/kio-locate/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>kde@gentoo.org</email>
- <name>Gentoo KDE Project</name>
-</maintainer>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
</pkgmetadata>