summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-misc/systemd-kcm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-misc/systemd-kcm')
-rw-r--r--kde-misc/systemd-kcm/Manifest2
-rw-r--r--kde-misc/systemd-kcm/metadata.xml14
-rw-r--r--kde-misc/systemd-kcm/systemd-kcm-0.7.0.ebuild28
-rw-r--r--kde-misc/systemd-kcm/systemd-kcm-1.2.0.ebuild33
4 files changed, 77 insertions, 0 deletions
diff --git a/kde-misc/systemd-kcm/Manifest b/kde-misc/systemd-kcm/Manifest
new file mode 100644
index 000000000000..d716adca5a86
--- /dev/null
+++ b/kde-misc/systemd-kcm/Manifest
@@ -0,0 +1,2 @@
+DIST systemd-kcm-0.7.0.tar.gz 52063 SHA256 8988e9b782546147e089c9ed86e65600cb9111ac7770dc4aa2fc8f862f4630cf SHA512 67658a97544148bc7a3208d00a0d990eea662f5e88032ff3d1d61f125ade1c3f36e0b1c772ab06fa90d954c9bf2c09436f0a5808d36373cbcf0687a57ff478c5 WHIRLPOOL 95087b293a20c3ddf0f880adecc4a48878199c835e743534fbedc633ddb751b8fa6b4d43f41bf0c730a19dcdc9b539b048f4a9b970607dc4a66b13e90cdfa508
+DIST systemd-kcm-1.2.0.tar.xz 79244 SHA256 d55147811b4a7b7082c5106fc746e8bb4927a0427db4e89cc706a1e92ae90ae7 SHA512 2827378d4ac533c4a774a898ae87c7a5198ecbc9887eb0591a42201e4b582fa113e0f0e887d0e5012f892898866f0c2aff8262f40d53223062baf52bcd64c89a WHIRLPOOL c5a7877f322f8025dd4bc98a56c8ef0e58ea02ad5ebb3be73634806c280fe5f3fdc61d07628308863d59c0cc3aede9dcc84ee764ca4ca1593eb64cee7f458ec9
diff --git a/kde-misc/systemd-kcm/metadata.xml b/kde-misc/systemd-kcm/metadata.xml
new file mode 100644
index 000000000000..cf728d3cff40
--- /dev/null
+++ b/kde-misc/systemd-kcm/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <longdescription lang="en">
+KDE control module for systemd. Provides a graphical frontend for the systemd daemon, which allows to view and control systemd units, as well as modifying configuration files. Integrates in the KDE System Settings dialogue.
+ </longdescription>
+ <upstream>
+ <maintainer status="active">
+ <email>rthomsen6@gmail.com</email>
+ <name>Ragnar Thomsen</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>
diff --git a/kde-misc/systemd-kcm/systemd-kcm-0.7.0.ebuild b/kde-misc/systemd-kcm/systemd-kcm-0.7.0.ebuild
new file mode 100644
index 000000000000..f9f31203857e
--- /dev/null
+++ b/kde-misc/systemd-kcm/systemd-kcm-0.7.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN="kcmsystemd"
+inherit kde4-base
+
+DESCRIPTION="KDE control module for systemd"
+HOMEPAGE="https://projects.kde.org/projects/playground/sysadmin/systemd-kcm"
+SRC_URI="https://github.com/rthomsen/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE="debug"
+LICENSE="GPL-3"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-libs/boost-1.45
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep kcmshell)
+ sys-apps/systemd
+"
+
+# only needed for 0.7.0 and 1.1.0
+S="${WORKDIR}"/${MY_PN}-${PV}
diff --git a/kde-misc/systemd-kcm/systemd-kcm-1.2.0.ebuild b/kde-misc/systemd-kcm/systemd-kcm-1.2.0.ebuild
new file mode 100644
index 000000000000..e5dffd4ec7f8
--- /dev/null
+++ b/kde-misc/systemd-kcm/systemd-kcm-1.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CMAKE_MIN_VERSION="3.0.0"
+inherit kde5
+
+DESCRIPTION="KDE control module for systemd"
+HOMEPAGE="https://projects.kde.org/projects/playground/sysadmin/systemd-kcm"
+SRC_URI="mirror://kde/stable/${PN}/${P}.tar.xz"
+
+IUSE=""
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ $(add_frameworks_dep kauth)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwidgetsaddons)
+ >=dev-libs/boost-1.45
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ sys-apps/systemd
+"
+RDEPEND="${DEPEND}
+ !kde-misc/kcmsystemd:4
+ !kde-misc/systemd-kcm:4
+"