summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-08-22 23:21:21 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-08-22 23:28:37 +0200
commitd1d7cdcae224154eede1ee6944f145946f1eff60 (patch)
tree12065a681fe2484b97689eba69518b952b0c93e4 /kde-plasma/kde-gtk-config
parentapp-doc/php-docs: [QA] Use relative symlink target(s) (diff)
downloadgentoo-d1d7cdcae224154eede1ee6944f145946f1eff60.tar.gz
gentoo-d1d7cdcae224154eede1ee6944f145946f1eff60.tar.bz2
gentoo-d1d7cdcae224154eede1ee6944f145946f1eff60.zip
kde-plasma: Add KDE Plasma 5.10.5
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'kde-plasma/kde-gtk-config')
-rw-r--r--kde-plasma/kde-gtk-config/Manifest1
-rw-r--r--kde-plasma/kde-gtk-config/kde-gtk-config-5.10.5.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/kde-plasma/kde-gtk-config/Manifest b/kde-plasma/kde-gtk-config/Manifest
index 13d30b88af17..1bdecf95ce36 100644
--- a/kde-plasma/kde-gtk-config/Manifest
+++ b/kde-plasma/kde-gtk-config/Manifest
@@ -1 +1,2 @@
DIST kde-gtk-config-5.10.4.tar.xz 152280 SHA256 32b126278fc89ec8f44126aa27569a02b0d913975b5b0d6021b126e1fa9eb364 SHA512 77605c02c419949412ccefeb86a345fcf35f82c474ca0820a1b3eaab16eb77eaae5c12b91766b543ff978ad771c428db047d307ab3fca4139f828a15b36e535e WHIRLPOOL 2ce1cfd723b0548535a3332c8620de8b0bce7199e813a184981b68b374d29e09add0617c9a292d3a3db513925504a87fd1273a579b6208d21c111a9012d57a1f
+DIST kde-gtk-config-5.10.5.tar.xz 152488 SHA256 a5bedaa880d416a8ab259c59dc84b4086a1cb8582d95d8632d79c3e9a746b8a8 SHA512 6043b8f37ec291bb0add449ea1a1777fef89d7aa246fac9af0fa4aa417e9c9551429a4c9ca1918d0079fb93e1bde13d82b1fdf83c615d2951f74558b013570a3 WHIRLPOOL 3125918af5ae52c2352845acd7c6f497294dc76e96885a53014e5127cdc046d9d0de1816814925f9f8d50f493331a5e5bfa86864575534a756db6908361e5bad
diff --git a/kde-plasma/kde-gtk-config/kde-gtk-config-5.10.5.ebuild b/kde-plasma/kde-gtk-config/kde-gtk-config-5.10.5.ebuild
new file mode 100644
index 000000000000..ebe684a9ff1f
--- /dev/null
+++ b/kde-plasma/kde-gtk-config/kde-gtk-config-5.10.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Plasma systemsettings kcm to set GTK application look&feel"
+HOMEPAGE="https://projects.kde.org/kde-gtk-config"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+gtk3"
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ x11-libs/libXcursor
+ gtk3? ( x11-libs/gtk+:3 )
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !kde-plasma/kde-gtk-config:4
+"
+
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}/${PN}-5.4.2-gtk3-optional.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DDATA_INSTALL_DIR="${EPREFIX}/usr/share"
+ -DBUILD_gtk3proxies=$(usex gtk3)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ einfo
+ elog "If you notice missing icons in your GTK applications, you may have to install"
+ elog "the corresponding themes for GTK. A good guess would be x11-themes/oxygen-gtk"
+ elog "for example."
+ einfo
+}