summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-11-22 18:25:38 +0100
committerJohannes Huber <johu@gentoo.org>2016-11-22 19:56:36 +0100
commit5d535b3729cf0fda0de5a9015916bfe0f4fe2a42 (patch)
tree9f7d9e62530ec56703c116c0ff59b6853517b58b /kde-plasma/kinfocenter
parentapp-crypt/pinentry: New upstream version 1.0.0 (diff)
downloadgentoo-5d535b3729cf0fda0de5a9015916bfe0f4fe2a42.tar.gz
gentoo-5d535b3729cf0fda0de5a9015916bfe0f4fe2a42.tar.bz2
gentoo-5d535b3729cf0fda0de5a9015916bfe0f4fe2a42.zip
kde-plasma: Version bump KDE Plasma 5.8.4
Package-Manager: portage-2.3.2
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/files/kcm-about-distrorc2
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.8.4.ebuild89
3 files changed, 91 insertions, 1 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index 260f55fb954c..648670834958 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -2,3 +2,4 @@ DIST glogo-small.png 24583 SHA256 0afc3eca084c327f8059166b86769f03c9c23e1e765bb4
DIST kde-workspace-4.11.22.tar.xz 13553668 SHA256 f035334e843d67ee88551ae9e6c5f64bf7b1edfe311b12501575fe74be0b03b7 SHA512 9def2cc8d1e597259966cd6cc44e9aad7ebe2c7cde5943e362c6782d1344e7da4fff0dddd0fe0c948bca159dba128d8a36006e1ae409415cd22f74955d0a9b95 WHIRLPOOL 14b0fcef19bda4b92a42612387fb6307a50dbb3620e911e3e0aaf5d764fb263e1959baae2e55cb71d92d064542844ae963b170bb960a9b7dc18a11627b731802
DIST kinfocenter-5.7.5.tar.xz 1248860 SHA256 f9cdf5575d332c4bd7f46238d3cd957a27b534a0e163d58fc7844bbc65115238 SHA512 3e08f2782004b56440395a5643f42b56a4adf6380eab15711a2397d20539e9116724f846f93a0db8bea9526f76db8c656fbda750e9742f5c9e0e33c060f0de1d WHIRLPOOL 5444078909e720501042aafc5420f60a2611d95f7cf578eee638d3f9a1d048830fcc2b66b607afa2a1c098a7cee70ea32eacb7e7604ccd7654ec0aca0a871618
DIST kinfocenter-5.8.3.tar.xz 1250572 SHA256 fb06f1eb28aab68a4659b999a6b991ea28165cc25c1ca2321515c25cc2f349c3 SHA512 849f7ae522ff5b195e4f983c1f3b7c9ba980522dc1836a1a80755ddd93dca441552c53a088019d3725ec44bbf07c94269d7be1a466528e8fb268ff93bb6a714b WHIRLPOOL 44ee4424d4fe107cd1c62fa91463c88b720ffb489785d99ade7108e921b579c5f252050fab9eb215f14bd37df537d54f0797b10a570ceffb5e2c8ae66e6909ef
+DIST kinfocenter-5.8.4.tar.xz 1276972 SHA256 6dafaf7fc5d74f959aa358b6247045fce4093a73863c25b1c3b76e3817b9dbd6 SHA512 af1ada09df84cd9e37d99d7c340b1e1c9e1568cae1ad09b1654e9390eea053e5013bc9a7855b7ea6613e2faea643ed142d1714c914ca9444edd12b8a0dd6943d WHIRLPOOL 692d07cdb8e77ba81d00c59cd2a1ab31a8b69f3685217af3588a0360bc89a891d172e81859e1d5612ad8e6387dc14a33ed40aaaabe735c48cd74a88d16ae4cd9
diff --git a/kde-plasma/kinfocenter/files/kcm-about-distrorc b/kde-plasma/kinfocenter/files/kcm-about-distrorc
index bdae77a9c687..b55389fd8bd1 100644
--- a/kde-plasma/kinfocenter/files/kcm-about-distrorc
+++ b/kde-plasma/kinfocenter/files/kcm-about-distrorc
@@ -1,4 +1,4 @@
[General]
Name=Gentoo Linux
LogoPath=/usr/share/kinfocenter/glogo-small.png
-Website=http://www.gentoo.org/
+Website=https://www.gentoo.org/
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.8.4.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.8.4.ebuild
new file mode 100644
index 000000000000..c9048810b95d
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.8.4.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="true"
+inherit kde5
+
+DESCRIPTION="A utility that provides information about a computer system"
+HOMEPAGE="https://www.kde.org/applications/system/kinfocenter/"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="egl gles2 ieee1394 +opengl +pci wayland"
+
+REQUIRED_USE="egl? ( || ( gles2 opengl ) )"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ x11-libs/libX11
+ ieee1394? ( sys-libs/libraw1394 )
+ opengl? (
+ $(add_qt_dep qtgui 'gles2=')
+ media-libs/mesa[egl?,gles2?]
+ !gles2? ( media-libs/glu )
+ )
+ pci? ( sys-apps/pciutils )
+ wayland? ( $(add_frameworks_dep kwayland) )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep plasma)
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !kde-base/kcontrol:4
+ !kde-plasma/kinfocenter:4
+ !kde-misc/about-distro
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package egl EGL)
+ $(cmake-utils_use_find_package gles2 OpenGLES)
+ $(cmake-utils_use_find_package ieee1394 RAW1394)
+ $(cmake-utils_use_find_package opengl OpenGL)
+ $(cmake-utils_use_find_package pci PCIUTILS)
+ $(cmake-utils_use_find_package wayland KF5Wayland)
+ )
+
+ kde5_src_configure
+}
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if ! has_version "net-fs/nfs-utils"; then
+ einfo "Installing net-fs/nfs-utils will enable the NFS information module."
+ fi
+ if ! has_version "net-fs/samba" || ! has_version "net-fs/samba[server]"; then
+ einfo "Installing net-fs/samba[server(+)] will enable the Samba status information module."
+ fi
+}