summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-03-28 22:46:29 +0200
committerJohannes Huber <johu@gentoo.org>2018-03-28 23:01:25 +0200
commit7b987bb059c77d82ef9b24b535e8a09430b9ac35 (patch)
tree202828e2af1320fe8f4218cb1aea662295840a78 /kde-plasma/kinfocenter
parentmedia-libs/openjpeg: Fix 2.3.0 USE=static-libs compile (diff)
downloadgentoo-7b987bb059c77d82ef9b24b535e8a09430b9ac35.tar.gz
gentoo-7b987bb059c77d82ef9b24b535e8a09430b9ac35.tar.bz2
gentoo-7b987bb059c77d82ef9b24b535e8a09430b9ac35.zip
kde-plasma: Version bump KDE Plasma 5.12.4
Package-Manager: Portage-2.3.26, Repoman-2.3.7
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.12.4.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index b15787996f8b..13594c2be866 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1,3 +1,4 @@
DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26c4af5e74c0622368aa4e34b05160fae15fbfbbc832077810ab5c1e424826632748299fd22997cbe665c SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48
DIST kinfocenter-5.11.5.tar.xz 1302960 BLAKE2B bd938c9c330c8f335825810e3fc8e8c97b1629d89bfeef0eb18bd4852f939f5ba0fb55640338b6d817c08d0b8f0099cdc303a19874811af52c35afd2a63a728c SHA512 d64cf466b4b883c9a57a0dddfe5a1d1cae0687655897803e5f14bcf73e90c1ea05d96458dbe131428c6d19a50d92b2614036136fdb897e422b1c1fc3d38f5303
DIST kinfocenter-5.12.3.tar.xz 1270096 BLAKE2B b788489c57817c0b60ea16afa23109eadff2478cf7e7016faadefcea8c8bb59ee17effb5e0243eda33dca70f58ac8e5dc69f85760d56967bbec74c532ba3cee8 SHA512 f82b5f2915547a7d258229115f82b085a88195a8e060224a4246194b98728b089040563f7450523e622946d65823e5cf348eb06fa614dade27c92f0725583317
+DIST kinfocenter-5.12.4.tar.xz 1267316 BLAKE2B cd4e253099aa20d7ee800043b1c83fec92ed75be84f815f6c732ae037b39a794c625621091bdd900f65101c446bf9ef1f3e4c23690138b17073daa645d57208a SHA512 56e93f9e71c94a3c6906d042e0b9c40cbbcce3d7494fe5e5833324014d11d79fe8d480967e08292eab43754688e9f4582cabc6af79609a9b88eb992235aead83
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.12.4.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.12.4.ebuild
new file mode 100644
index 000000000000..ff2f95c95937
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.12.4.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="true"
+inherit kde5
+
+DESCRIPTION="A utility that provides information about a computer system"
+HOMEPAGE="https://www.kde.org/applications/system/kinfocenter/"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="gles2 ieee1394 +opengl +pci wayland"
+
+REQUIRED_USE="wayland? ( || ( gles2 opengl ) )"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ x11-libs/libX11
+ ieee1394? ( sys-libs/libraw1394 )
+ opengl? (
+ $(add_qt_dep qtgui 'gles2=')
+ media-libs/mesa[gles2?]
+ !gles2? ( media-libs/glu )
+ )
+ pci? ( sys-apps/pciutils )
+ wayland? (
+ $(add_frameworks_dep kwayland)
+ media-libs/mesa[egl]
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep plasma)
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !kde-apps/kcontrol:4
+ !kde-misc/about-distro
+ !kde-plasma/kinfocenter:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package gles2 OpenGLES)
+ $(cmake-utils_use_find_package ieee1394 RAW1394)
+ $(cmake-utils_use_find_package opengl OpenGL)
+ $(cmake-utils_use_find_package pci PCIUTILS)
+ $(cmake-utils_use_find_package wayland EGL)
+ $(cmake-utils_use_find_package wayland KF5Wayland)
+ )
+
+ kde5_src_configure
+}
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if ! has_version "net-fs/nfs-utils"; then
+ einfo "Installing net-fs/nfs-utils will enable the NFS information module."
+ fi
+ if ! has_version "net-fs/samba" || ! has_version "net-fs/samba[server]"; then
+ einfo "Installing net-fs/samba[server(+)] will enable the Samba status information module."
+ fi
+}